WebAdmin interface missing on new AR760S

I just bought a Slate (AR760S). When I first turn it on and connect to it via, I don’t get the Web Admin interface. Instead I get a LuCi OpenWRT interface in Chinese. The username on the LuCi is root but I don’t know the password. I have tried ‘goodlife’ but it didn’t work.

What is the default password for LuCi? I have searched all over the internet but haven’t been able to find it.

I have also hard-resetted the router but I have not been able to get the WebAdmin interface.

I would be grateful for any suggestions or solutions to this problem.

Thank you.

Clear your browser cache, or try a “Private” window (Firefox) or “Incognito” window

Thanks for your suggestion. I tried that but it didn’t solve the problem. I managed to contact Gl.Net support and at the end, there was a problem with the firmware. I had to re-flash the firmware using Uboot. Thank again.

Hi, You mean AR750S?
There is no Chinese interface in LUCI by default. Is it your browser’s automatic translation or a firmware issue? Is it resolved now?

Hi. It wasn’t my browser translating the web page. It was in Chinese.

. I finally managed to solve the problem by replacing whatever firmware it was in the brand new router with the current AR760S firmware using the Uboot procedure. That solved the problem.

Oh, I see. The picture show is not GL.iNet Official firmware.