What is the exact way to restart the WAN and renew the Ip address on AX1800

I tried, but there was nothing in the syslog. No restart at all

Did you start the cron daemon after adding the crontab? You can reboot the router to start cron.


I reboot the router, it runs. However, the IP does not renew, and the wan interface is still up without any interuption.

cron runs commands in a background process. Did you check after >70 seconds?

maybe just restart network

/etc/init.d/network restart

This would restart all network connections, including both LAN and WAN.

Maybe just reboot the router if willing to wait >70 seconds anyway.

Weird, I rebooted the router, no new IP generated

Why do you want to have a new IP address? Dynamic IP addresses are issued with a “lease period”, which could be hours, days, weeks etc.

Unless your ISP has a specific policy, you will get the same IP until the lease expires after not being connected, even across disconnects/reconnects. Even after the lease has expired, you may happen to get the same IP again the next time.

My WAN IP from my ISP has been the same for months and I do not remember when it was last changed.

I used to use AX3000 ASUS router, my IP renews every time the router reboot (via scheduled task on its ASUS WRT firmware). This thing does not happen when I use Flint, weird
I tried
32 4 * * * sleep 300 && touch /etc/banner && /etc/init.d/network restart
But still get the same IP address
I have some specific activities on the Internet that need new IP address to work with

I dunno if OpenWrt can do that:

Yeah, this is exactly what happened to me. I tried many commands, nothing works ):

Hi vinnfts:
You could clone the MAC address and check if it renew ip.

32 4 * * * ifconfig eth0 down;sleep 2;ifconfig eth0 up

With this command, I still get the same IP address ): It’s really weird, because with different router, every time I reboot, a new IP address is generated.

I have tested it.And each time I restart the PPPD(eth0), it can obtain a different IP address.

So I want to check whether the upper-layer pppoe service has any restrictions on the MAC address.

What worked for me after setting up scheduled task was to start the cron with the command below:

/etc/init.d/cron start

No router restart was required.