When GL-AR300M16 (firmware v2.27) loses wifi signal the router goes into a spin

My environment’s SSID space looks as follows…

  • The WiFi signal I am trying to connect to has a weak signal strength; I will call it HotelWiFi; it is a secure network.
  • There are other Wifi SSIDs available of comparable signal strength; one of which I will call OtherWiFi; it is an open network.
  • The router repeater SSID is called MyWiFi; it is a secure network.

The steps to create multiple problems are as follows…

  1. Connect the router to HotelWiFi. The router connects successfully and the internet is available.
  2. Move the router to a spot where the signal to HotelWiFi is lost.
  3. Move the router back to the original spot where the signal to HotelWiFi was ok; ie. the position in step 1.

After step 2 a serious problem arises…

The router’s repeater signal MyWiFi repeatedly starts (repeatedly) dropping out, then reappearing, dropping out,… This problem appears soon after step 2 above, but can take a minute to manifest itself. (Rebooting the router doesn’t help after step 2 or 3; you find the repeater signal doesn’t appear for ages and when it does the same behaviour is observed where the router’s repeater signal repeatedly starts dropping out, then reappearing, dropping out,… Any number of reboots does not help.)

The only way to get out of this predicament is to either factory reset the router or enter the GLiNet admin webpage ( when possible and repoint the router at HotelWiFi. Until you do one of the above the router is in endless spin.

To repoint the router at HotelWiFi via the GLiNet admin webpage there appears to be a gui issue in the Internet Settings > Repeater dialog.

Continuing from where we left off above where the router is in an “endless spin”…

Logging into the GLiNet admin webpage shows the router has instead picked OtherWiFi. This is unexpected as OtherWiFi has never been connected to before; whether the router is actually connected to OtherWiFi is unclear; perhaps it’s just the dropdown listbox not displaying accurately. The only way to reselect HotelWiFi is to choose the HotelWiFi and reenter the password; eventhough HotelWiFi was supposedly remembered via the “Remember this network” check box on the Internet Settings > Repeater dialog it isn’t. How can you repoint the router at HotelWiFi? Selecting it and leaving the dialog doesn’t select it. Alternatively selecting it and clicking “submit” is greeted with “Cannot update wan” eventhough the password field says “Leave Blank to keep unchanged”; ie. you must enter the password to repoint the router at HotelWiFi.

For the repeater issue, it is a unstable in v2.x firmware, would you mind to upgrade to the latest testing firmware? Which is more stable. It is available in http://download.gl-inet.com/firmware/ar300m/testing/.

Please don’t ticked “keep settings” when upgrading.