Where to get firmware for GL-AR300M?


I borked my device and need a firmware image to flash with uboot.

It’s the old version of the GL-AR300M, the one with NAND.

I have tried openwrt-ar300m-3.216-0321-1679391450.img but that did not work and openwrt-ar300m16-3.216-0321-1679391734.bin but that does not use NAND and I don’t have enough space to install the packages I need.

Are older images for the AR300M with NAND still available somewhere?
Many thanks!

For uboot, the .img file is correct. As AR300M has two flash, you can just flash two times using uboot, once using the .img to flash the nand flash, the 2nd time use the .bin file to flash the nor flash.

After that, try boot the router.


first of all many thanks for your support.

Unfortunately this did not work…

Here is what I did:

In the beginning I updated uboot. I now have the version where you can configure if the button should select the NAND/NOR mode. I enabled that and put the slider into the NAND-position.

I then flashed openwrt-ar300m-3.216-0321-1679391450.img but there is no indication of when the procedure is finished as the device never seems to boot again (no wlan visible either).

So after a while I started uboot again to flash ar300m16-3.216-0321-1679391734.bin.
This time the device rebooted in NOR-mode, I could log in via the web-interface.

However when I now reboot the device it comes up in NOR mode - so flashing the img-file does not seem to have done anything.

What could I try?

You should use the uboot in this repo https://github.com/gl-inet/uboot-for-qca95xx/tree/master/bin

You do not need to use the switch button to control which flash to use. Uboot will do this automatically based on .img or .bin.

That is the uboot version I use.

But my divice only boots in nor-mode.

If you set up boot from the Nor in uboot, pls clear the setting. If the the router refuse to boot the Nand firmware in any way, maybe nand flash is demaged.

Do you have UART to get the uboot console output?

What setting could I clear? I tried to disable the buttons now and flashed the nand-firmware again but it comes up in nor mode.

I don’t have UART.

There was a uboot env. GL-AR300M (Shadow) - GL.iNet Router Docs 3

But maybe you didn’t use it at all.

So I tried to set boot_dev to on and move the slider into the NAND-position - but still the system boots into NOR mode.