Which EasyTether IPQ driver does the B1300 need?

Been searching the forum, docs, google, etc but can’t seem to find the right info. TIA.

1 Like

Well. After process of elimination by: Installing. Every. Single. Driver. Version. Manually…

It appears Convexa-B (GL-B1300) is not compatible with EasyTether, as there is no EasyTether driver for “that architecture” (3.105 / 15.05.1), even though GL docs specifically state it does at Internet - GL.iNet Docs (scroll down to the bottom).

Please update your docs, they are inaccurate and now I need to send five routers back to amazon.

To help avoid this situation going forward please advise me if the following routers are compatible with EasyTether, and please specify which EasyTether drivers they use:

Slate (GL-AR750S)
Convexa-S (GL-S1300)
Brume (GL-MV1000)
Beryl (GL-MT1300)

If it is actually possible to use EasyTether with Convexa-B (GL-B1300), please explain how.


This thread still needs a response fyi.

Also, which are the fastest gl routers that support EasyTether (in terms of cpu, ram, data throughput speed)?

Granted, the original post was made over the weekend but it’s now Tuesday. Two business days+ and still no reply from support. Kind of makes you wonder if they just prefer the thread sinks into oblivion rather than defend their position when someone calls them out on inaccurate documentation.

Or is it a national holiday this week in China ?


If you search “when is Chinese New year” in Google, you’ll see an Easter egg.

1 Like

Ok, thank you for that.


!remindme in 1 week

  1. No where on the page does it say that it is officially supported. Actually it says the total opposite “Note: Easytether is not a free service and we have no affiliation with them”. The guide is generic for all routers, up to the user to see if it works or not. It is in no way supported or official.
  2. The drivers for B1300 and S1300 would be on this page:
    Download EasyTether drivers - EasyTether for Mac OS X, Windows, Ubuntu, Fedora and game consoles

Clicking on -openssl to download all the drivers:

OpenWrt 15.05.1 (instructions): -openssl

A quick look in the zip file, there is no IPQ4xxx only something similar IXP4xx.

You can try that driver.

There is also an OpenWrt 19.07.3+ download, that one does explicitly have a IPQ4xxx. Notice you will need to flash vanilla OpenWRT without the GL UI and proprietary drivers in that case, which will remove Mesh and give you slightly worse wifi performance.


Johnex: a very good answer, thank you.

The IXP4xx didn’t work, but your last paragraph outlined a way forward. I’ll try that and report if I have any issue.

Thanks again.

You may need to use OpenWrt 1907 firmware from OpenWrt Firmware Selector

You lost the original UI though.

This works well on the gl-b1300 convexa is you are running openwrt 19.07.10 and you install kmod tun through luci and select the easytether openwrt 19.07.03+ tiny package instead of openssl. so you do not need the libopenssl1.1 that is a dependency for the openssl package and instead only need filename- kmod-tun_4.14.275-1_arm_cortex-a7_neon-vfpv4.ipk you can upload this from Luci on the router user interface click on software and it will allow you to upload and install the kmod tun ipk. after you have done this you can follow the directions on gl-inet easytether setup for putty install of the easytether tiny package. once you have installed the package and restarted the router - after inputting the appropriate command into putty to the router to setup the easytether adapter before you restart it. Go to interface in the router and “add interface” whatever name you want make it unmanaged connection. Then next you will be able to select “tap-easytether” on the interface page after adding the new interface. connect your phone to the router after setting up the easytether app on the phone and turning usb debugging on. When you connect the phone to the router it will prompt you on the phone to allow or deny usb debugging. Once you have selected allow your connection is established. on my samsung phone i have to use midi as the usb option. on my google phone i have to use PTP as the usb option. I hope this helps because after three days of research and trying different things this is what finally worked for me to get the gl-inet gl-b1300 convexa to work with easytether app direct from my phone instead of needing a pc passthrough or using the metered standard tether connection that gets throttled. say bye bye to throttle and hello to data.

1 Like

Yes, easy tether does work on the mt1300. You just have to get the right driver and know how to install it