Which IPK Driver Package For Slate (GL-AR750S-Ext) For EasyTether

I’m trying to follow the instructions to enable EasyTether on my new Slate (GL-AR750S-Ext) router.

https://docs.gl-inet.com/en/3/app/tether/

The instructions say to identify the chip of your model which I believe for the Slate is the Qualcomm QCA9563 (Dragonfly). Right?

Per the instructions I’ll use WinSCP and I’m suppose to find the IPK file of the router in EasyTether driver file which I have to extract and install on the router.

The instructions list a few example routers but not the Slate (GL-AR750S-Ext). Nothing appears to stand out as the appropriate driver.

Suggestion on which one I should use? Help?

Just a suggestion - I think it would be beneficial if the instructions included a complete matrix of routers to drivers so someone a little less technical could follow the instructions and use the correct driver.

PS: I’m trying connect a Motorola Moto Z (Droid) cell phone to the Slate via the USB port using EasyTether.

Thank you in advance!!

Why do you want to install it manually? You can set up tethering in the default admin web page, isn’t it?

Thank you for asking. Normally if you have a cell provider that offers tethering as part of your cell service you should be able to just plug in your cell phone, enable tethering on the phone and away you go. However, my new cell provider does not support tethering but offers a lot of data as part of their service. Normally you would tether a computer to a cell phone and you have to install an app on the computer and an app on the phone and the two apps communicate between each other to form that link. Since the router is not a computer I have to find a way to install some code on the router’s USB port that makes it look like a computer to the phone. Using EasyTether on the router and the phone enables one to use the cell phone as is if it is normally tethered like a phone to a computer. Using EasyTether you still set it up the software on the phone which then “talks to” the software on the router. I hope that helps…

Well the good support folks at GL.iNet got back to me with info as to which IPK driver package to use but the Slate router is still not communicating with the phone. The router appears to “see” that something new is plugged into the USB port because the Tethering option starts and it prompts me to click on the green “CONNECT” button. However, what’s interesting is that when I use a cell phone that offers tethering as part of the normal cell service the tethering device is labelled “usb0” and works perfectly. When I attach my other cell phone that the provider does not “officially” support tethering, the device is labelled “eth1” and never connects. When I use that cell phone tethered directly with a computer and I use an app called PdaNet on both the cell phone and the computer the cell phone / computer combo works just perfectly. Something is still not right between the router and the cell phone using EasyTether. Oh, while following the process to implement here:

https://docs.gl-inet.com/en/3/app/tether/

After entering easytether-usb while in Putty I did receive a message about something not being available. Maybe something about the USB port? Sorry, I thought it was normal so I ignored that and kept going. Any suggestions about what to do to make this work is greatly appreciated…

It would be help if you show the log here. You can ssh to the router, and execute the two commands.

logread
dmsg 

I would be happy to provide any logs. FYI, I’m more a hardware guy so getting this log is not second nature to me. I don’t know what ssh to the router means or how to do that.

However, I’m real good at following instructions so if you provide me the steps I’ll be happy to get the log.

Also, the router is currently powered off. If I power the router back on will the log still be there or will you want me to attempt another connection and then send the log? Just wondering…

Thank you!

You need to hit he connec button and after it failed, give the log as said.

As said in emails, usb0 or eth1 does not matter. Seems your easytether driver does not work properly.

I’m speaking from experience here. I’ve done exactly what you are trying to do.

http://www.mobile-stream.com/beta/openwrt/easytether-usb-openssl_0.8.9-4_openwrt-18.06.2.zip
The file you want is in ./*/ar71xx/generic
(Always grab the latest version from http://www.mobile-stream.com/easytether/drivers.html. The one you want is “OpenWRT” w/ openssl)

Btw, there is a way to setup tap-easytether as a fallback connection. The way I have my slate set up is I use Ethernet (WAN) as the top priority, followed by Wi-Fi repeater, followed by EasyTether. I did this by setting up a separate interface instead of replacing the existing WAN interface in the network file. Set the metric for Ethernet to 10, set the metric for Wi-Fi repeater to 20, and set the metric for EasyTether to 30.

My router is currently “rented” out of state atm and I won’t be able to see it’s configuration for a month or so until I get it back, but when I get it back, I can walk you through the steps to set up fallback connections, if you are interested.

Hope this helps!

P.S. Btw, if you can figure out why easytether stops working after a while, let me know. It’s been driving me nuts to have to unplug and replug the phone back and forth into the router to start back up the internet for easytether.

I had a lot of problems with constant disconnects and I thought it was the GL-AR750S-ext. But after days of fiddling with the router and easy tether, I found that easy tether was not compatible with either the phone (F60) or the Kit Kat OS. I am not sure which. But using a different phone with 5.1.1 lollipop, the connection is stable and doesn’t disconnect.