Wifi adapter in usb AR-150

hello my problem . how to connect wifi adapter ralink 3070 in ar-150 the same problem here OpenWrt Forum Archive here OpenWrt Forum Archive

image

config wifi-device 'radio0'
	option type 'mac80211'
	option hwmode '11ng'
	option path 'platform/ar933x_wmac'
	option disabled '0'
	option htmode 'HT40+'
	option noscan '1'
	option channel '6'

config wifi-iface
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option encryption 'psk-mixed'
	option ssid 'MyAP'
	option key 'mypass'

config wifi-device 'radio1'
	option type 'mac80211'
	option hwmode '11ng'
	option path	'platform/ehci-platform/usb1/1-1/1-1:1.0'
	option disabled '0'
	option htmode 'HT40+'
	option noscan '1'
	option channel '1'

config wifi-iface 'sta'
	option device 'radio1'
	option network 'wan'
	option mode 'sta'
	option ssid 'public-wifi'
	option key 'passpass'
	option encryption 'psk-mixed'

I read your link but I am not sure what is your problem exactly.

I just tried and it works find with you config.

One note is to comment the ifname in wan in /etc/config/network


config interface 'wan'
# option ifname 'eth0'
  option proto 'dhcp'

not working

openwrt

usb wifi adapter not connected in client mode

wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option channel '1'
	option hwmode '11ng'
	option path 'platform/ar933x_wmac'
	option htmode 'HT20'
	option disabled '0'

config wifi-iface
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option encryption 'psk-mixed'
	option key 'goodlife'
	option ssid 'GL-AR150-64a'

config wifi-device 'radio1'
	option type 'mac80211'
	option hwmode '11g'
	option path 'platform/ehci-platform/usb1/1-1/1-1:1.0'
	option htmode 'HT20'
	option disabled '0'
	option channel '8'
	option country 'US'
	option txpower '18'

config wifi-iface
	option network 'wwan'
	option ssid 'anna_87'
	option encryption 'psk2'
	option device 'radio1'
	option mode 'sta'
	option bssid 'E0:19:1D:62:D3:D4'
	option key 'mypassss'

network

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd66:67b7:4126::/48'

config interface 'lan'
	option ifname 'eth1'
	option force_link '1'
	option type 'bridge'
	option proto 'static'
	option ipaddr '192.168.8.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wan'
#	option ifname 'eth0'
	option proto 'dhcp'
	option hostname 'GL-AR150-64a'

config interface 'wan6'
	option ifname '@wan'
	option proto 'dhcpv6'

config interface 'wwan'
	option proto 'dhcp'

where you can download the firmware clean openwrt? for ar-150

that’s how I’m doing https://youtu.be/P4_gNWNjYKk?t=131

please give instructions or video how to connect wifi adapter in GL-AR150 that he worked in client mode

Can you click the “Scan” button of the Radio1 and get a list of ssids?

Seems that the “Encryption” of the client mode is not displayed. I am not sure if this is a problem.

alzhao

I am sorry that I can not explain to you properly
Well, you know the problem
If you do connect the adapter in GL-AR150 you understand the problem

Hi, actually I did connect and tested without any problem. So this is why I am asking.

Are you connecting to a public ap or your own ap?

The problem that you cannot get connected as sta, mainly due to wrong encryption, password or channel. Can you double check these values?

Also there are another problems:

The first time you post your configure, you only have “wan”, no “wwan”. So I told to comment “wan”. The only thing left is to check the sta info: ssid, encryption, password and channel.

The 2nd time you posted your configure, you have “wwan”. When you create “wwan”, you need to configure it in firewall as well, i.e. change /etc/config/firewall, add “wwan” where you have “wan”. A little complicated.

alzhao

hi, I solved the problem
the problem was that my adapter has a 5 meter cable
tell me how to give the GL-AR150 greater power USB port

Good to Know. Long cable always cause problems.

Do you have 5V2A AC adapters?

alzhao
not work 5V2A AC
may try 6V or 7V AC not burn router? I also tried 5V 700mA not work

I see. Don’t use more than 5V. As voltage is not changed, so high current doesn’t work. Don’t know how to make it work. Maybe use a better wire.

I do not know I think it’s a normal cable
cable

I buy a try
cable

the problem is bad design of ar150. i’ve connected it to 5V2A adapter which measured with multimeter give out 1.6A and attempting to use usb wifi device always result in ar150 rebooting. i had to connect it to 5V3.5A usb port on my PC to work stable.

i gave up on this and bought tp-link with baterry.

If you look at your system log (dmesg) you are certain to see the device is disconnecting and reconnecting over and over, that is why you were having the problem. It starts out as phy0 and it will just keep reconnecting like phy2, phy3… forever. The cable length will likely not fix it, it is a result of a lack of power available to the port.

You may be able to solve it by reducing the transmit power (option txpower) to something between 10 and 20. I believe it defaults to 30 and the router cannot handle that much output.

You have a few solutions…

  1. run it from a POWERED usb hub
  2. modify the router so the USB port power (+/-) comes directly from the 5V power supply.
  3. Add capacitor on both the power and ground 5V USB power. It may help alleviate any surges on startup or peak power that would cause it to disconnect.

The power adapter provided is supposedly 1A, and 5W should be plenty for the device and USB adapter I would imagine, but you could try a 2A rated power supply and see what happens.