Wifi Calling not working with GL-SFT1200 over Starlink

I’m trying to troubleshoot why Wifi Calling won’t work with my GL-SFT1200. I’m just using the GL router directly connected to Starlink. I’m not using the Starlink router in bypass mode. If I use the Starlink router, Wifi calling works consistently. With the GL, my phone never connects to Wifi Calling. I see no affect on speed or ping when testing over the GL vs. Starlink router. During testing there is no demand on the connection.

It’s possible the GL-SFT1200 doesn’t support this, but I can’t determine that from what I’ve found. I’ve messed with QOS. Nothing I try solves the problem. I’m trying to use a travel router to conserve power. I run this on an RV battery system. I don’t need range on Wifi.

Wifi Calling works over SIP, just like VoIP. Many routers have SIP ALG enabled by default, which often causes problems:

Try the following on your GL-SFT1200:

I do not work for and I do not have formal association with GL.iNet

1 Like

@ramyana were you able to resolve your issue? I’m having the same problem. I tried the suggestion given but it didn’t work.

I never was able to get it to work. I ultimately returned it and bought the higher end version of the router. WiFi calling worked straight out of the box. It must be some limitation of the low end router.

It’s the AXT1800.

2 Likes

I got it to work by do the following

  1. Opened port 500 UDP
  2. Ooened port 4500 UDP
  3. Ooened port 143 TCP
  4. Set channel fixed to channel 6

Well it worked one day then the next back to not working :frowning:

I finally got it to work with the help of support@gl-inet.com . First I installed WinSCP and logged into my router on WinSCP, found the file /etc/modules.d/nf-nathelper-extra and added a #to the beginning two lines:

  1. #nf_conntrack_sip
  2. #nf_nat_sip

Saved, logged out, rebooted router, and tried calling on my phone in airplane mode and I still get the massage “”turn off airplane mode to make this call” . Then support had me install putty so I could write these lines into the router code:
uci set firewall.@defaults[0].flow_offloading='0
uci set firewall.@defaults[0].flow_offloading_hw='0
uci commit firewall
/etc/init.d/firewall restart

See this link for instructions on using putty SSH to the Router - GL.iNet Router Docs 3 (gl-inet.com)

After this wifi calling worked on my GL-SFT1200 opal router.

2 Likes

Rad! This was super helpful. I’m assuming I got the putty part right but writing directly to the command line, but this seems to be working well now.

Would be good to hear from support to know if there is a better solution than turning off hardware acceleration. This degrades the speed of the WAN connection massively, I don’t think it is an adequate solutiuon, a workaround at best

@admon is there a better solution to this please that doesn’t require disabling HW acceleration and slowing down the WAN connection?

I don’t know.

But since the GL support that disabling HW offload seem to solve this issue … I would assume this is the way to go.

@admon Is there any chance this can be looked into as I feel like this is just something in the firmware, maybe firewall rules or something that’s not made it across to the 1200 setup.

The new mt 3000 wifi 6 router runs fine with hardware acceleration on and wifi calling works, I know it’s a big assumption, but would there be a massive difference from a hardware perspective on the WAN ports?

It does work fine if you use the router in STA mode, which obviously it’s then not using the WAN port, so it’s definitely related to the WAN port in some way.

Cheers

@admins would like to also give an update that with the new starlink gen 3 dish, wifi calling works fine without disabling hardware acceleration.

Something has got to be a miss here, it can’t be a wan port hardware issue, has to be something in the configuration surely?

Wifi calling also works fine when I plug into my home broadband. It is just when it’s plugged into the starlink gen 2 dish.

If anyone can help on this it would really be appreciated

Cheers

if there are any logs or anything I can run and provide to help, please let me know

I had the same problem. I install a new GL-SFT1200 opal updated to latest 4.3.11 and wifi calling simply did not work.

Tried opening ports and a bunch of other stuff and the only thing that worked was entering the commands in SSH
uci set firewall.@defaults[0].flow_offloading='0’
uci set firewall.@defaults[0].flow_offloading_hw='0’
uci commit firewall
/etc/init.d/firewall restart

I didnt change nf-nathelper-extra.

I had an older GL-SFT1200 opal with older firmware possibly from 2021 and it did not have this issue with wifi calling so I suspect something was introduced in firmware that kills wifi calling since then. I can’t tell you what the old firmware was as the unit died due to water ingress.

1 Like