WiFi Client to Wired Transparent Bridge

mt300n running firmware 2.25:

I’d like to give use the GLI to bridge the printer to the Wi-Fi network (b/c the printer’s wifi is terrible). The printer’s set at the router to get a static IP of based on its MAC.

The GLI connects to the router via wifi fine. I can access it over

Here’s what i have:

https://i.imgur.com/ho8Jrbf.png (where I’ve entered the printer’s wifi MAC. it doesn’t show up here, but the router’s DHCP sees a client as the printer’s MAC and gives it

I can no longer access the advanced settings. brings me to the same interface as the screenshots above.

I’ve connected the printer to the LAN port on the GLI. But I cannot add the printer in Windows 10. It doesn’t see the printer using the default add mode. I can add the printer specifying the IP address manually, but it doesn’t print the test page.

The two scripts (/usr/bin/switch_mode and the BTN_1) came with the router and are already chmod +x. The switch is to the right - I haven’t touched it.

SO I have two questions:

  1. How do I make the GLI completely transparent, so I can add the printer? It would be nice to be able to access the GLI on :83, but if that’s not possible when the GLI is transparent, that’s OK.

  2. How Can I make the physical switch useful to go between transparent bridge mode OR a wired to parent router and serving as a wi-fi AP?

Clone mac is not the right way to do this. Because when you connect the printer to MT300N it is behind the firewall. It can still access the Internet but now, from your main router, is MT300N, not your printer. The printer can only be seen in the same subnet, not behind a firewall.

To make MT300N totally transparent, here is what you can do.

  1. If you want MT300N connect to your network wirelessly, you can either use WDS (if you main router support this). WDS can be set up directly in the UI. If your main router doesn’t support WDS, you may need to consider relayd, which could be a little difficult to setup. Check docs here: Overview - GL.iNet Docs

  2. If you can use wired bridge, that could be much easier. You can just (a) bridge eth0.1 and eth0.2 (b) remove WAN (c) disable firewall. All these should be done in Luci.

To use the switch to change between bridge (only wired, not WDS) and route, we are implementing this in the UI and hope to release it soon.

The MT300N has to be wireless. So I will try WDS.

A) What is the LAN IP to be entered in the WDS setup? The IP of the printer OR the IP the MT300N receive from the main router’s DHCP (both MACs are static) OR … ?

B) The main router is Tomato 3.4-138. I imagine I have to change the 2.4ghz to be AP + WDS. Which MAC address do I enter on the tomato router?


The LAN IP that MT300N can use. For example, you set the IP to, then later you can access MT300N using this Ip address.

You need to enter MAC address on your Tomato router? Why? I don’t know Tomato.

Please remove the mac clone from MT300N as well.

I’ve reset the MT300N.

Via a wired connection I:

Set the password

Created a custom Wi-Fi Hostspot then disabled it.

Changed the Hostname

Set the DNS servers

All good this far.

But then I:

Set the Internet connection to WDS, with the IP the main router is set to give to the MAC address of the MT300N.

Set the Tomato Router to AP + WDS, and entered both the bottom and the top mac addresses that were listed in “Clone MAC” (I didn’t touch the setting, I only copied the values).

Now I:

Cannot access the MT300N via, or My printer, set to obtain a DHCP address via the wired connection and plugged into the MT300N, is not visible either. It’s web interface doesn’t come up either.

I bought this exactly for this purpose. I might have to return it to Amazon if I can’t get it to work. I already have a Tomato router and a Raspberry Pi, I am not looking for another device to tinker with.

If you don’t have to, just don’t touch the mac clone. I mean that you don’t need to input mac address in your Tomato. You just input an available IP ( when you set up WDS. Just to avoid wrong settings.

WDS in different chipset (driver) may not works with each other. I am not sure if this is the case, but you need to check.

If you have problem with WDS, you can press down the reset button, the middle LED starts to flash once per second. After 3 second it will flash quicker, release your finger and it will reset the network. Replug in your cable so that you can get access to 8.1 and start again.