Will the GL-AR300M16 support connecting to a WPA2 Enterprise network

Read title. Will the GL-AR300M16 be able to connect to a WPA2 Enterprise with no CA Certificate (Don’t Validate) using the EAP Method with PEAP as well as using MSCHAPV2 (not really needed but just in case) If it doesn’t can someone recommend a good product that can, or at least a guide to using a raspberry pi to use wireguard to host an AP and how to get WPA2 Enterprise on it as well? I really hate having to dig into files to get stuff working. I do have a CanaKit Wi-Fi USB dongle on the way if that can somehow help connect to the network in either case (the GL-AR300M16 or Raspberry Pi)

I already have a gl-mt300n-v2 and found out very fast that it doesn’t see the network! (yay) And every forum post, mainly by @avatar4 didn’t help, None of the tips worked and I’m really not good with OpenWRT this is even before having to set up wireguard which is needed in my case!

Thank you,
Airplane :smile:

Also just wanted to add

How come a problem with the drivers for the mt300n-v2 to support connecting to WPA2 Enterprise networks has never been resolved? (or in fact, any of the GL iNet devices that can’t connect) This has been an issue since 2017. Is the problem the fact that the Wi-Fi chip being used simply doesn’t have what’s needed on the chip to connect to WPA2 Enterprise networks?? Knowing that WPA2 Enterprise is just for security I’d assume that it would be software/driver-based, but I am not a network engineer (my knowledge ends at port forwarding!) and I’m sorry if this is a dumb complaint, no hate towards any of the devs who work hard making any of the drivers or devices!

It supports this feature.

It is supported in 4.x firmware, you can try to test it.

Oh, I did try switching to the beta as I was writing that post with no luck, The pictures below were just taken now. I do not see a space for the username for the Enterprise log in. Maybe I’m doing something wrong?

I’m sorry, I made a mistake;

EAP was supported using the openwrt open source driver, but since testing found the open source driver to be unstable, glinet reverted to using the mtk closed source driver.

does this also effect the GL-AR300M16 or just the GL-MT300N-V2?

AR300M16 support connecting to EAP.
MT300N-V2 does not support connecting to EAP.

Hello! I just got myself an AR300M16 (Amazon link of the product I ordered) and sadly it can’t see the network. Am I supposed to be using the beta? Am I doing something wrong?? I tried to add it by clicking “Other” and picking “802.1x EAP/WPA2” but it doesn’t have a place for a CA cert (but that’s fine as our network doesn’t need one) and as soon as I click “join” the wifi point goes down and comes back up but no luck, still not connected. Please let me know what my next steps should be!

Small update: using the advanced config (Luci?) I was able to add the network manually (doesn’t show up on scan) but it doesn’t connect and the AP point for the router is now unavailable and not coming up so I have to use a wire. When I’m connect to my phones hotspot I can see the strength of the enterprise network connection changing but I didable my phone hotspot and the router doesn’t connect to the enterprise network and the AP is now unavailable. I did install wpad but that didn’t seem to do anything to help… I’ll try switching to the beta and see if that works. (Slightly busy so it might be awhile till I’m able to test the beta)

Just tried the beta and no luck!

(As seen all networks are printers, none are the one I’m looking for)

Pls don’t install wpad as it is already installed.
The default UI only support username and password. For CA you must use luci to configure.

Can you pls check what is the channel your EAP wifi is using? AR300M16 can only connect to 2.4G wifi, 1-11 channel by default.

Pls click the small info icon in your windows wifi connection and find out what is the wifi channel it is using.

For the CA if the default is set to none then it should be fine (if it’s set to the system CA then I will need to use Luci)

Just checked what channel the network is on and it’s on channel 100 (??) and it’s 5G… What should my next steps be? I have a CanaKit Wifi dongle can that help at all?

Big bummer :frowning: Hopefully I can do something.
I also still have my mango if that can also help at all.
If nothing works I’ll unfortunately have to use a PI (I was trying too avoid that due to the power demand)

as your wifi is 5GHz. There are two ways to solve your issue:

  1. Set the wifi network to 2.4G if you have control.
  2. Choose AXT1800 which support EAP and 5GHz.

What other models support EAP and 5GHz (and channel 100) preferably on the cheaper side? Do GL-SFT1200 or GL-A1300 support these requirements?

A1300 support EAP. But channel 100 is DFS channel. Only AXT1800 is DFS certified.