Windows VPN L2TP/IPSec Issues

Good Evening,

I use T-Mobile internet, and was using the provided home router, and a Archer C9 router with DDWRT. I bought a GL-X3000 so I could go away with having T-Mobiles provided modem/router and get rid of my Archer C9 and have it combined into one using the GL-X3000.

I’m having trouble with connecting to 2 VPN sites using L2TP/IPSec with the built in Windows VPN. Before I switched to the GL-X3000, I was able to connect just fine with the Archer C9 flashed with DDWRT.

What I have tested is if I have my SIM card in the GL-X3000 I cannot connect to either VPN. If I use T-Mobile’s modem/router and have the GL-X3000 plugged up behind I can connect, but I can’t hit websites or talk to other devices on either VPN.

I’ve tried putting my laptop through the DMZ and tried to connect, but it doesn’t work either way if using the GL-X3000 with the SIM card or without. If I plug my laptop straight into the T-Mobile router/modem, I can get connection and can hit websites with the L2TP VPN.

This makes me think something within OpenWRT’s firewall settings is blocking the VPN connection? I’m stumped, I’ve read other threads, but I can’t get anywhere to get this to work. I have other VPN connections I use like OpenVPN client on my laptop to connect to other remote sites, and it works just fine, I just can’t connect with L2TP/IPSec.

UPDATE: I hooked back up my Archer C9 with DDWRT behind T-Mobile modem/gateway. So right now I have both the GL-ATX1800 and GL-X3000 behind Archer C9. After testing the VPN connection with the GL-ATX1800, I was curious if it’d work with the GL-X3000 behind the C9, and it works. To try and narrow this down I’ll back track what I tried.

TMobile SIM + GLX3000 = no connection

TMobile NAT + GL = connection but no internet (can’t see VPN network)

TMobile NAT + DDWRT Archer C9 + GL = connection (Works Perfect)

I noticed in the settings for DDWRT it had a option to allow VPN pass-through. Which I’d assume that’s why it works with my DDWRT router, but what I find weird is if I remove the Archer C9 from the picture, the GL doesn’t connect out, but why? The GL-X3000 is the router I need to use with my TMobile SIM, the ATX1800 is just an extra I had for playing around with.

Playing with this router, I’m starting to believe that the modem doesn’t support the protocol?