Wiregaurd/OPVN issues

I’m actually having two issues if anyone can help. I have horrible cellular service in my house so my phone doesn’t work indoors without internet. Using wiregaurd all phones at my house go straight to voicemail. As soon as I disconnect it, they work again. I read something about lowering MTU and know how, just don’t fully understand it so haven’t been testing.

Then I switched to OpenVpn which takes my normal 500mbps down to ~150mbps. Wiregaurd around ~250. I’m ok with openvpn for split tunneling features. Here’s the weird part. Using the standard openvpn file worked fine. Then I made some changes to bypass a site. Worked perfect. Then I went to add multiple sites to bypass and now openvpn doesn’t work at all even reverting back to the unedited file. Used many different servers, mostly UDP but tried TCP too. It works from the computer so I think something got corrupt on the router. The logs say something about unable to find directory /tmp/run/opvn_resolvedip “no such file or directory. Using putty I could verify that does not exist. Using advanced features I have verified opvn has been updated.

Any help would be appreciated!

I’m just going to offer some unsolicited advice regarding MTU & WireGuard: start at 1240 or 1280 & increment by 10 until you find something stable. 1420 is the max.

Thank you for reaching out and trying to help. Unfortunately I could not get it to work on any number in increments of 10 from 1240-1420. Who knows if it’s actually changing the MTU. It says applied when updating but still not working.

grep mtu /etc/config/wireguard will show whatever’s been applied to the saved profile’s MTU. You’d still need to disconnect & reconnect WG via the GL GUI though. See below for resources to gain access via SSH (typically root@

logread is also available to read the full system logs. logread -e firewall is an example of how to ‘filter’ for firewall related entries. wg is for WireGuard. I don’t know about OVPN as I don’t use it. You may be asked to post your ip route given the OVPN + VPN Policies difficulties.

Don’t forget to include your device model & firmware version (GL GUI → System → Upgrade → Online Upgrade).

Thank you for your time. I’ll have to check tomorrow as I have limited time with twin 2 year olds. Their smart cameras play white noise and disconnecting interrupts their sleep. I ssh using putty yesterday to review directories but not even a beginner level Linux user. This helps and I can definitely browse files and check those logs you suggested. As you probably know based on your comment I did get lazy and start applying MTU’s without dc each time. The first 3-4 I did, but was running out of time and started cheating. Thanks again, I’ll give it another run shortly.

1 Like

The message about not being able to find a file or directory I think is a sign that no connection is being made. Ignore it–I think your problem is earlier than that.

Thank you, that makes sense actually. I tested it with a bad password intentionally and got the same message. I wonder if I just need my VPN to issue me new credentials. The fact that it worked before any configurations and now it doesn’t restored back to factory defaults is suspicious.

I got new credentials and the connection works. Now it has no internet but it is making a connection. It’s ok, I think I have abandoned the idea of getting OpenVPN to work due to slow connection speeds. I’m going to work on getting WG to work. The only thing missing is how to allow devices connected to make/receive WIFI calls. I have very limited cell phone coverage in my house. Thanks again for the advice.

Now I’m having problems with connections being made but what I think are DNS issues. They used to work, so I think this is on the VPN provider side. I need to find some time to poke at this.