Wireguard Client Connected to Server but no Internet

Hey everyone. For a number of months, I’ve been working using a travel router connected to my router at home. However, I just bought two glinet GL-AXT1800 routers to replace what I was using. I’ve set up the wireguard server at home, did port forwarding, and have no problems there. It works and has internet.

The issue is with the client. I connect successfully, but there is no internet. I’m not sure what’s going wrong.

Here is the configuration code given from server. The only difference is I changed Endpoint for DDNS:

      Address =
      ListenPort = 13020
      PrivateKey = xxxxxx
      DNS =
      MTU = 1420
      AllowedIPs =, ::/0
      Endpoint = [...].glddns.com:51820
      PersistentKeepalive = 25
      PublicKey = xxxxxxxxx

Again, the server shows a successful login and connection by the client, but client has no internet. Is there debugging I can do to try to figure this out? Keep in mind I’m a beginner. If I can’t figure this out is there someone I could hire to help me?

Thanks in advance for your help. If I can provide additional information, please let me know.

ISP - Xfinity
Xfinity router IP -
Device IP address (server router) - (port forwarded)
MTU - 1420 (I’ve also tried 1280)
Server IPv4 Address - (changed from 1 to 7 to avoid collisions)
Services from GL.iNet Use VPN switched off

Are the lanip of your two axt1800 the same? If so, please modify the lanip of one of them. Otherwise, could you please help send the detailed information of your VPN Dashboard interface

They are different. Server router is and client is

Let me know if you can see the photos below:

Is there any chance I could pay you or anyone else for your time to help troubleshoot this via remote troubleshoot session?

Hello, I can see the photos, could you please tell me the firmware versions of your two axt1800? We will verify whether this is a problem. If there is no problem on my side, I will ask someone to help you check through remote session.

Version 4.2.1 on both. Sounds good, I appreciate your help.

In the meantime, I verified ipv4 forwarding and tried changing the DNS but I still haven’t been able to get internet.

I ran the test. It’s working fine.We can set up a time for a remote session to help you sort this out

Ok sounds good. Are you available today or tomorrow? Let me know what works for you

I just communicated with my colleague. Please refer to this first to see if it is caused by this reason. If not, we can help you solve it remotely laterhttps://forum.gl-inet.com/t/wireguard-vpn-server-not-working-client-connecting-but-nothing-loads-openvpn-works-fine/28947/18?u=hansome

Ok I’m about to go to bed but I will look at this again tomorrow and let you know, thanks

I couldn’t sleep and decided to give it a try. It worked! I changed the server ipv4 to 10.20.0.X/24 and now I have internet access. Thank you!

As a side note, it looked like if I turned off ip masquerading I would lose my connection. So I guess this is important to have on.