Wireguard client doesn't connect on AR300M

I’ve setup my own wireguard server and it works fine from an iOS device and Windows 10 (didn’t try Android but should work) but it doesn’t have any traffic on my AR300M router. It connects fine but doesn’t turn green? Any idea what’s up?

Here is my client config that works from iOS/Windows10:

PrivateKey =
Address =

PublicKey = mUIpd94Otr4/aITmu4p2PMsw9k3OI+GYXLYPMYMkZGY=
PresharedKey =
Endpoint = ipaddress:51820
AllowedIPs =

I noticed that there is a Listen Port in Interface but there is nothing in the actual client config. I entered the same as the endpoint but not sure if that is correct?

Any other way to debug this? It’s stumped me since it works fine on other clients.
PS. I have tried with DNS server but that’s not the issue here.

OK I figured Listen Port is just a random port so that is not the reason it doesn’t have any traffic.
Any other ideas?
I tried both manual input and copying the config file contents.

It has this issue in old firmware, we had fixed it. It is available in next release.

Could you please ssh to the router, and execute this command? Please show me the result.


C:\Users\user1>ssh root@
root@’s password:

BusyBox v1.28.3 () built-in shell (ash)

| |.-----.-----.-----.| | | |.----.| |_
| - || _ | -| || | | || || |
_____|| |
||||___||| |____|
| W I R E L E S S F R E E D O M

OpenWrt 18.06.1, r7258-5eb055306f

root@GL-AR300M:~# wg
Warning: one or more unrecognized netlink attributes
interface: wg0
public key: PLvQGyhYy4YTeBI1kjqUAFr/CT9J5rvCxo7TR3DlhHU=
private key: (hidden)
listening port: 28459

peer: mUIpd94Otr4/aITmu4p2PMsw9k3OI+GYXLYPMYMkZGY=
endpoint: :51820
allowed ips:
transfer: 0 B received, 1.30 KiB sent
persistent keepalive: every 25 seconds

Any ideas on this one please?

@kyson-lok Do you need any other details/information?

Missing IP address in here. Did you mask it?

I saw your config contains PresharedKey before, the old firmware doesn’t support it, we had added it in new firmware. Could you please PM your email to me? So I send it to you.

Yes the ip/hostname is masked in the output.

In the meantime, I received my new 750S and I tested the same wireguard client conf file and it has exactly the same behavior. The current firmware is 3.025. The firmware with PresharedKey support is newer than 3.025? I will send you a PM to email. Thank you.

Thanks, I tested and it works fine now. Wireguard client connects successfully. I should leave the MTU field blank? I tested with 1400 but I am not sure if that is a good value or has a different impact? Thanks again.