Wireguard client GUI not working

Wanted to create a manual wireguard client config on my GL-MT300N-V2 with gl-mt300n-v2-3.012, but the GUI is broken. Clicking the ok/save button does nothing, even everything is filled out in the GUI.

Try to get firmware 3.022 from

This is actually a bug in old firmware for manual input.

Thank you, upgrading to openwrt-mt300n-v2-3.022-0329 solved the issue, wireguard connection is working now. A few question though, why does the GUI require you to set a client port? Isnt it generated random, I dont think youre requiered to set a client port actually.

I also get a bit low performance I think, I get around 25mbit. faster than OpenVPN which was around 7mbit, yes, but I expected something like 40+mbit. Shouldnt the GL-MT300N-V2 get a wireguard result like that?

The speed could depends on the server as well. In our test the router could achieve 40+ without problem. But network speed also matters.

You are right about port. It is not necessary but for some reason this was required in config. We will check and fix.

Actually, the listening port is an optional. It is identical with WireGuard’s configuration. If someone send a configuration file to you, which contains a listening port, it won’t has wrong.

Than this is a bug in the GUI, it wants a client port, otherwise you cant click next/ok. So I just put a random bogus client port into the GUI. I have nother question though, does the implementation of GL-INET works differently? Because I see this weird device using some construct, a device called apcli0 for example. And the config for the wireguard is also a bit different than the standard default Openwrt config for wireguard.

I think we had fixed this bug, doesn’t it?

This interface is created by MTK’s closed wireless driver.

GL.iNet has its own configuration file and init script.

Thank you very much for the information. I have an issue right now with wireguard, and I have no idea what is causing it. The connection works fine, but I cant reach the lan behind the server from the lan behind the wireguard client router. If I do a ping -t (that is a lan behind the server), and the wireguard connection isnt etablished so far, connect, the ping goes through, but after about 10-15 seconds after the wireguard connection was etablished, the ping and any connection to the lan part stops working, as if the server executes some firewall or route scripts in the first 10-15 seconds after the wireguard connection was etablished, and blocks any connection from the wireguard client (and lan behind it), to the lan from the server wireguard router.
Both are OpenWRT routers, the client is my GLi-Inet one. Any idea, what could cause this? I tried everything so far, to make it work, but it doesnt so far.
wg0 is in client firewall zone on the server:

config zone
option name ‘lan’
option input ‘ACCEPT’
option output ‘ACCEPT’
option forward ‘ACCEPT’
option network ‘lan wg0’

not working. I then tried a seperate zone, with:

config zone
option name ‘wire’
option input ‘ACCEPT’
option output ‘ACCEPT’
option forward ‘ACCEPT’
option network ‘wg0’

config forwarding
option dest ‘wire’
option src ‘lan’

config forwarding
option dest ‘lan’
option src ‘wire’

not working.

The first 10-15 seconds after the first wireguard connection, it becomes not reachable anymore. And stays unreachable, until I reboot the server router. Doing again a first wireguard connection, ping works for the first 10-15 seconds to lan, then gets blocked again.