Wireguard client won't connect to Flint server

I'm helping someone with their Wireguard setup and whenever they try connecting any client (for example, a Slate AX or an iPhone with Wireguard app), the internet gets killed and it doesn't make the connection (only yellow indicator light). The Wireguard server is running on a Flint (firmware v4.5.16) with 51820 port forwarded from the Xfinity router to the Flint. The Wireguard server indicator light is green in the web admin panel, DDNS is turned on and the client config files are using the DDNS. Internet works fine on the Flint server. I saw a similar post about someone trying a newer snapshot firmware to fix the problem so I'm having them try v4.6 in the meantime (Update: did not fix).

Here is a screenshot of the server log:

I also saw an older post where the OP said: "Ok, the issue was list allowed_ips ‘’
I’ve replaced it with and it works flawlessly, thanks for any input folks!" But that doesn't make much sense to me since 0.0.0./0 would cover the IP they replaced it with.

Could it be the Xfinity's firewall rules are too strict? Would that prevent clients from connecting to the Wireguard server? I'm having them try bridge mode for the Xfinity router now which should answer that question.

Try this. If adguard is enabled just disabled it for now.

Head over to Network > DNS

Find "DNS Server Settings" and change the mode from what it's currently selected to any of the options and click apply, then change the mode back to "Automatic" and apply and you should see "DNS from WireGuard" with an IP listed underneath "DNS from Ethernet"

Before doing what I suggested can you actually see any text underneath "DNS from ethernet" that says "DNS from WireGuard"?

I noticed on my brume 2 there was a DNS issue but when I reapplied to "Automatic" mode I then got the Wireguard DNS setting info to appear on that page and resolving worked.

Once you have done applying the DNS setting you can then re-enable adguard home (if adguard home is enabled you can't see the DNS server settings on the client GUI) I also have all the options currently toggled off on the DNS section too.

See if that helps...

Please read How to troubleshoot WireGuard to make sure you checked everything.

The Yellow Dot status shows that the wireguard server is not reachable.

So pls give all of these screenshots:

  1. xfinity wan status showing your WAN IP. You can mark part but we need to see that the WAN IP is a public IP, not private IP.
  2. Port forward settings on Xfinity.
  3. Wiregurd server status of the Flint router.

Update: User was able to get it working just by switching the Xfinity router to Bridge mode. I suspect the firewall security was set too high on the Xfinity gateway. Unable to confirm.