Wireguard connection issues

still playing around with X300B.

Uploaded our test config file for WIREGUARD as client which works smoothly with other routers.
It connect and we do have internet through X300B.
IP also is the fireguard IP.
That’s OK

I tried to open some ports on routers so I can connect to X300B through wireguard.
See screen shots.
It didn’t worked.

I can’t ping X300B
I can’t reach it neither via SSH, nor via GUI (http80)
Of course… I’m connecting from another network (home, while X300B is in office), using a different wireguard config, while connected on the same wireguard server of the X300B.

Before you ask me… yes, when I use the same config file with another router and when I open the ports 22 and 80 on that router, I can access from my desktop (different network) also connected to same wireguard server.

Where am I mistaking ?
Thanks for help

Do you have this turn on?

If yes you should not need to set up firewall and open ports

Thanks for your reply.

NO ! It was OFF
In attachment the screenshot of that.

Here below is the ping while I was connected with my laptop from home (X300B in office different internet connection/isp)
My laptop got IP
My server is
X300B is
ZBT WE826 running 19.07 stock using different ISP is
As you can see:

  • I can ping SERVER (
  • I can ping ZBT WE 826 (
    but I can’t neither ping nor reach X300B (

I then decided to (1) disconnect WIREGUARD in X300B, (2) switch ON “Allow Access Local network”, (3) delete rules in OPEN PORT IN ROUTER and reconnect WIREGUARD

As you can see
NOTHING changed.
Still unreachable…

By the way before you ask me… if I use the ZBT WE826 wireguard config, result is again the same. (now the X300B) can’t be pinged or reached.


Although I rebooted X300B several times, each one after any changes before try wireguard etc…after to have updated the firmware just now to 3.203… IT’S WORKING !!!

I have a question…
Which of the two way is better to use.
(b) The other way around: ALLOW ACCESS LOCAL NETWORK switched OFF and use rules on the OPEN PORT ROUTER.


I think only a) works. But I may be wrong.

a) Only allow input from vpn interface.
b) Allows port from wan and vpn interface. When vpn is not on, the port is still open on wan. But you can do some detailed settings in LuCi