Wireguard, DDNS, and Goodcloud

Hello,
I have a weird question about Wireguard, DDNS, and Goodcloud.
My current version of GL-AR750S-220 is 3.024 (just updated). I read https://docs.gl-inet.com/en/3/app/ddns/

Scenario:
Home1 = Router -> GL-AR750S-220 Wireguard SERVER, DDNS enabled (port forwarded), Goodcloud enable and I can see it online from goodcloud.xyz
Home2 = Router -> GL-AR750S-220 Wireguard CLIENT, DDNS enabled (port forwarded), Goodcloud enable and I can see it online from goodcloud.xyz
I can access using http://XXXXXX.glddns.com without any issue (to both) so I want to establish VPN between them.

If “Enable VPN Policy” is ON at Home2, I cannot connect Wireguard to the server at Home1, so I turn “Enable VPN Policy” OFF. Then I can connect Wireguard but I got kicked out from my remote management, I have to go “locally” (192.168.8.1) turn again “Enable VPN Policy” ON and I gain remote access again, the problem is that I have no physical access to local to Home1 so often

Finally, when I have “Enable VPN Policy” ON Goodcloud shows GL-AR750S-220 OFF.

  1. How can I connect wireguard remotely without been kicked out?
  2. How can I have wireguard connected and Goodcloud showing GL-AR750S-220 ON?

Thanks for your time!
JUAN PABLO


I got that configuration in VPN Policy.

Did you try to clear all rules? If not, could you please have a try?

1 Like

Hi I did clear all the rules and change to “use only vpn for… all websites” and it worked!!! now I got access everywhere!
Thanks for your reply