Wireguard local network access

I try to setup wireguard on the AR750s as a VPN into my local network. Connecting with clients (phone) does work but I can’t access any local IP (server). Is this a bug or as designed?

I have the same problem. try using zerotier or try this.

Can’t access the server’s LAN? How do you access it? If the WireGuard is established, you should be able to access server’s LAN.

This is my current setup:

Add the IP range look at the link I provided

In this topology, Mobile phone can access the server. But you have to configure port forwarding from Router to AR750S(Extender).

I had tested just now, without any problem. Here is my topology. My phone doesn’t install WireGuard app, so I use Slate instead, it should be the same.

I see I have a completely different problem. Any client I connect to my slate does not have Internet. Doesn’t matter if I add the slate via WIFI or network cable to my network. I guess as soon as I figure out what goes wrong wireguard might also work.

If the Slate works as WireGuard server, but it does not have Internet, so the mobile phone can’t established with it.

Could you please take a screenshot of the INTERNET page?

O.K. I got the problem. When I connect to the WAN port with my network cable I only get Internet if I enable the Access Point mode. But then the WireGuard configuration disappears. If I connect a network cable to the LAN port I get internet but the AR750s does not recognise it.

Was you set it in MORE SETTINGSNetwork Mode?

Let’s just conclude that it is way to difficult to setup. I might manage to configure it for my location but I will not be able to help my colleagues to setup there end. I really have hoped for a much nicer UX.

We are developing create site to site network in cloud, it should be very easy to set up, but no soon.