Wireguard not connecting - bug?

Hi, My wireguard profile stopped working. When I checked the configuration file, I found that the endpoint was a numerical IP address, and did not reference the *.glddns.com dynamic ddns name. This means it works until my IP address changes.

The profile comes from an AR750S and looks like this:(numbers altered!)

Address =
ListenPort = 14299
PrivateKey = =

AllowedIPs =,::/0
Endpoint =
PersistentKeepalive = 25
PublicKey = nu979n99ALhSQQClKi4QgbmAif0Q1Xb7plmIsl5wRbiXLsUU=

The Endpoint is the problem! My IP address changes regularly it should look like:
Endpoint = oc5d999.glddns.com:51820 then it would not stop working when my IP changes.
Although it might need a restart on the client.
Both text and QR code profiles are affected.

I have tried to edit the profile on the client, an Android phone, but the change does not seem to be saved in the profile. I have done this successfully for other clients - my linux laptop for example.

Can someone confirm this please?

1 Like

You can just replace your endpoint with your ddns.

I am not sure why you said it does not apply in your app. Maybe it is app problem.

I finally managed to hack saving the changes into the wireguard profile.
So, I have solved the problem, but but there are two classes of people.

One set who have fixed IP addresses - the current arrangement works fine for them.

The other set have no control over the numeric IP address and would benefit from being able to pass the DDNS name across to the profile, without having to edit it.

Just a suggestion ; 7 )

1 Like