WireGuard not working because the default DNS is down for a long time

Please forward this to the firmware developers if possible, maybe they will want to make a change in the next update.
The WireGuard profile default DNS is (Verisign), which is down for quite a while now (months?), according to many forums worldwide. I know some things here and there about networking and it took me a few hours to figure out the problem, but unknowing people that set up their routers following easy Youtube videos might believe their routers are faulty. If the developers could replace it with (VeriSign that works) or (Cloudflare) or (AdGuard) or whatever they think is best for users without any experience, it would make people's life easier.

For anybody having problems connecting to their WireGuard Server on their router, go to the Profiles section, click on the Gear -> Set More -> and replace the DNS with one of the above or google yourself for secure DNS server. Don't forget to export the profile and load it in your client.


Works fine for me

dig forum.gl-inet.com +short @

I have the default: in my wireguard config, works fine.

What do you use to connect? It doesn't work for me on the WireGuard app on my Android phone or Windows 10 laptop. The error messages I got from the browsers said something about DNS solving, I forgot exactly what. Also if you ping, you will get no reply. If you google this problem, you will find people complaining about this server, being down for a few good months on various forums. The only change that I did was replacing the DNS in the Profiles and worked flawlesly from first try. works fine as a DNS resolver. So your problem seems to be a different one.

1 Like

I just done a DNS query without using the VPN server. The time I tried the default DNS server in Wireguard it did work for me. But I'm not able to test that right now

Could that server be blocked for certain geographical areas? I'm currently in Romania and can't get even a ping reply from it. Like I've said above, changing it solved the problem immediately.

Could be, but I doubt it: Ping server, ping website : Check host - online website monitoring