Wireguard On Mt300N V2 DNS

Hi I’ve been experimenting with Wireguard on my Mango router - it appears to be working but the VPN is still using my ISP DNS servers. How can I force it to use a DNS server of my choice such as Cloudflares service.

Many thanks,


pls try below procedure

You can also set custom DNS for now.

Daer Alzhao,

I’ve set custom DNS in the GLi gui but it has no effect with Wireguard. I’m trying to connect with the MT300N as a server and a Debian Gnome PC as the client. The system always uses the DNS set in Network manager on the Debian pc.

Any ideas ?



I see. You can enable DNS override in the router and try.

I’ve tried that myself, I’ll reply there so as not to clutter things up here

The PC will always try to use its own DNS server. The router is able to override the DNS settings on the PC if DNS resolve data is not encrypted. But I think wireguard broken the DNS override.

Dear Alzaho,

I think you’re right and Wireguard has broken the override DNS function.

I’m now thinking of using a MT300A as a client for Wireguard and connecting the pc to MT300A instead of running Wireguard on the pc.

Is it possible to run Wireguard on the MT300A using the 2.26 software (as 2.27 has broken the SD-card access on the MT300A) ?



I don’t think 2.26 has wireguard.

Is the SD card not recognized or share function is broken?

Dear Alzhao,

The SD card is not detected in 2.27 but flashing back to 2.26 fixes the issue.

I reported this bug a while ago on the forum ;(



here to report same issue with my mango wireguard server, no DNS over tls no matter what, override client dns is checked, still no use

my own solution was only enabling private dns on android 9+

Edit: DNS leak problem solved by specifying DNS at wireguard client configuration, set it to the server router’s (the one that has DNS over TLS enabled) local address (not VPN address)

SOLVED: Its a config issue, easily fixed, but time consuming to find it!

Navigate to: More settings | Custom DNS Server
Set DNS Rebinding Attack Protection - OFF
Set Override DNS Settings For All Clients - ON

It should now use the DNS in the Wireguard configuration.