WireGuard over Port 53


Does anyone know of a way to set the WireGuard server to use port 53. When I try to save the configuration the GUI says that I have selected an invalid port. Thanks

Have you already disabled dnsmasq and any other DNS servers?

If i remember correctly you are not allowed to use ports lower than 1000. Try setting a higher port :slight_smile:

Thanks. I was hoping to use port 53 to get around a strict firewall. Thanks

Try setting the port via config files and see if it works?

1 Like


This doesn’t seem very smart - 53/UDP is DNS, and this can fall back to TCP for records that are too long.

GUI is right - it’s an invalid port.

Look at ports 80/443 instead.