Wireguard Routing at client


#1

Hi,

i have a Question to get my setup running.
I hava a Router (FritzBox) an in the internal Network is a AR750s with the WAN Port (IP:192.168.114.45) On this Interface a Wireguard Server is running. In the Router i activate a Port Forward to .45 for Wiregard.
I generate two Client in Wireguard, one for my iPhone and a second for a remote Site. iPhone Connect works well.

At the remote Site is a AR750 behind a FritzBox. It can connect as Client to my Wiregard Server.

Now i want to connect from 192.168.114.x to the remote Network behind the AR750. But this wont work.

What can i Do?

Regards
Christian


#2

You can ssh to the AR750S(WireGuard Server), and add your AR750’s(WireGuard Client) LAN subnet to it. Please mind the LAN subnet should not conflict with server side.

image


#3

Hello,

thanks for the fast reply. The solution works if i come from the Subnet behind the Server 750s. But i want to come from the .114 net at the Servers WAN. At my FritzBox i set a static route to 192.168.8.0/24 to 192.168.114.45. So traceroute find the 750s but ther is a route missing, i think.

My Firmware at the Server 750s is 3.0013 and i activate Remote Access.

A second Question now: Where can i find the documentation to all possible options in the config.

Regards
Christian


#4

In this case, I think you have to enable a forward rule from wan to wireguard.

You can try to add those lines into /etc/config/firewall, and restart the firewall.

config forwarding
        option src 'wan'              
        option dest 'wireguard'

Sorry there isn’t such document for it, but we will add it soon.


#5

Hi,

thanks this works fine for me.
Is it poosible to deine more than one Subnet at the Option “Subnet” in your first answer.
I have tested many versions, but no one works.

Regards
Christian


#6

Yes, it can. It is a list option in uci, so you can add more than one subnet. But it depends on the topology in server side.