WireGuard server on Flint 2 but no connectivity to clients

After working with a Beryl travel router for a year I am looking to upgrade my system. I have purchased the Flint 2 router and set it up with a static IP address supplied by my ISP. It is currently connected to my main home router via ethernet cable, and I also have port forwarding set up and DDNS turned on.

I then used the GL.iNet admin panel to set up a WireGuard server which appears to have been successful, however when I try to connect a client (laptop, phone, Beryl travel router) I no longer have internet signal on that device. I have no idea what I am doing wrong, even after reading thorugh several forums and guides. It’s my first time setting something like this up, so any clear guidance would be much appreciated!

My ultimate goal is to have the Flint 2 set up as a VPN server so that I can connect from it globally using my travel router or other necessary devices. Please help!

Pls post the Internet connection settings of Flint 2 and how do you set up port forward.

As you said you set up Flint 2 with a static IP supplied by your ISP and connect to your main home router, it seems not correct. The static IP supplied by your ISP should only be set up in your main router.

Sorry, I misspoke. I set up the Static IP on the main router and the Flint 2 is connected to that router via ethernet cable. I set up my port forwarding in the router admin panel (see attached pic).

Despite port forwarding being set up, the device IP and the router IP don’t seem to match, with the router IP having 2 fewer numbers at the end ( router showing 192.168.1.x and Flint 2 IP showing 192.168.1.xxx). Plus, when I search my IP addres on Google on a computer connected to the Flint 2, it shows an entirely different IP (actually, this IP matches the IPv4 # shown on my Linksys router admin panel). What do I need to change so that my devices begin taking on the same static IP when connected to the network?

  1. Googles show that your IP matches the IP shown in Linksys router. This is good.
  2. I don’t understand what is matching and waht is not ( router showing 192.168.1.x and Flint 2 IP showing 192.168.1.xxx). Pls send screenshot of these one. You don’t need to mark these IP as they are internal IP addresses.
  3. Need to check your wireguard config. What is in the end point setting? Your public IPV4? or something?

Thanks for your reply. If I understand correctly, my routers actual IP address is, which is also shown on the Internet page of my Flint 2 admin panel since they are connected via ethernet. My assigned static IPv4 address is 208.86.67.xxx, and the wireguard configuration is shown as this

Sorry I can only post one screenshot at a time. Let me know if you need more info!

This is what it looks like when I have my Beryl set up as a client. Does it seem correct?

Have you thought instead of Global Proxy , try to test it with “VPN policy based on client device” and test it with one device at a time ?

Global Proxy works fine for me on Flint 2 though.

Also are you using Flint 2 in addition to your home router ? So are you double NATing ?

It would probably help if you showed the diagram + IPs for your LAN via something like https://draw.io/ , but take out important IPs and such.

The client router looks just fine. So seems everything is OK now?

I tested it today on my phone. It seemed to be mostly fine, but a few times I noticed I didn’t have internet connectivity, but this seemed to resolve as soon as I turn the VPN tunnel off. What could this be indicative of/ how can I resolve this? During the times I was connected to the server and had service, the IP address came up correctly as the one from my home router.

I plan to use this to work from other locations. My question is, if I am far away from the server and something goes awry, how can I resolve issues if I can’t access the admin panel without being directly connected to that wifi network?

You can bind the server router to your goodcloud account so that you can control it remotely, if this is what you want.