Wireguard server on GL-B1300 with Android Hotspot?

I have a flatrate 5G mobile SIM and currently I use it at home as the router by activating the Android hotspot to connect my laptops to the internet.
At home I have two routers GL-inet B1300 and TP-WR902AC with OpenWRT.
I connected the B1300 to my Android hotspot and my devices at home can connect to the B1300 wifi and have the internet access. With this setup I created a local LAN with the IP 192.168.8.X, which differs to my Android hotspot (e.g. 192.168.100.X). So far so good, and I don’t need to use my second WR902AC router.

Now, I would like to use the wireguard VPN. What is the appropriate setup for my situation since my B1300 isn’t connected to an internet provider and assigned to a public IP address?

My first trial today has failed. I’ve just set up the wireguard server on B1300, copy the configuration on my Ubuntu 22 laptop to /etc/wireguard/wg-b1300.conf , and start the wireguard client with wg-quick. Afterward my laptop doesn’T have access to internet.

Is it possible to setup a Wireguard server with my setting? If yes how?

With the GL-B1300 behind the Android hotspot, you need port forwarding from the Android device to the WireGuard server on the router. Android does not have port forwarding built-in, but there may be apps that can be installed to do that.

I suggest you can look into using AstroRelay.

I do not work for and I do not have formal association with GL.iNet

Thanks for the hint!
I found an app called Fwd: port forwarder. However, it has 7 trackers.
I’ll try the AstroRelay then.

You may not have a public IP on your Andriod, thus cannot use it as a server. So Astrorelay should work for you.

I created an AstroRelay account and a link for the WireGuard Server. Then, I connect to my router wifi, changed the endpoint in the wg configuration file under /etc/wireguard/. If I activate the wireguard client on my laptop, I can’t connect to internet. As a test, I can access the dashboard of my router from another link agent that I created.
How can I troubleshoot this issue?

Update: It seems to work now. My question is now, using such a setting, I won’t see any different of my public IP, isn’t it? I get the same IP either with enabled or disabled wireguard client.

You shoud not change the endpoint in the wg configuration. You should change before uploading to the router.

You need to give me details of your setttings, with screenshot. If you cannot post the details here, pls use email support at glinet.biz