Wireguard Server works, Slate cannot connect

Hi,

Device: Slate.
I am having issues connecting to a Wireguard Server setup on a Raspberry Pi at home in the UK.
My ISP in the UK is BT.

Here is the weird thing: I can connect to the server just fine with Wireguard on my phone. It connects, my IP changes to my home IP, everything is fine.

Using the same config file to setup the client on my Slate, I can connect to my server however there seems to be no connection afterwards.

Any ideas as to what this could be due to ?

Thanks for any help !

Firmware version?

Maybe just set up a custom dns?

Maybe just try this firmware https://dl.gl-inet.com/firmware/snapshots/20210703/ar750s/

You may want to try a test with a lower value for the MTU setting on both your Pi and your Slate. I saw the same problem on a cloud VPS where I could connect with Wireguard but not transfer any data. I ended up setting the MTU on both sides to 1320 which fixed the problem.

Hi, thanks for your answers !

@eric I tried your suggestion by setting the mtu value in the /etc/pivpn/wireguard/setupVars.conf file to 1320 and 1280. I then created a new client configuration file for each one in succession and tried again and still no luck…

@alzhao, how would a custom DNS help ? and why change the firmware.

I forgot to mention the first time round that I was able to connect to a Pi running Wireguard with pivpn in France from the Slate, and it worked fine.

Any further ideas ?

Thanks !

New firmware solves bugs, which may matter.

One more thing I could think of is the port.

Go to the router’s wireguard settings, find out the detailed configuration and you will find a local port. Change that to anther one.