Wireguard Server works, Slate cannot connect


Device: Slate.
I am having issues connecting to a Wireguard Server setup on a Raspberry Pi at home in the UK.
My ISP in the UK is BT.

Here is the weird thing: I can connect to the server just fine with Wireguard on my phone. It connects, my IP changes to my home IP, everything is fine.

Using the same config file to setup the client on my Slate, I can connect to my server however there seems to be no connection afterwards.

Any ideas as to what this could be due to ?

Thanks for any help !

Firmware version?

Maybe just set up a custom dns?

Maybe just try this firmware GL.iNet download center

You may want to try a test with a lower value for the MTU setting on both your Pi and your Slate. I saw the same problem on a cloud VPS where I could connect with Wireguard but not transfer any data. I ended up setting the MTU on both sides to 1320 which fixed the problem.

Hi, thanks for your answers !

@eric I tried your suggestion by setting the mtu value in the /etc/pivpn/wireguard/setupVars.conf file to 1320 and 1280. I then created a new client configuration file for each one in succession and tried again and still no luck…

@alzhao, how would a custom DNS help ? and why change the firmware.

I forgot to mention the first time round that I was able to connect to a Pi running Wireguard with pivpn in France from the Slate, and it worked fine.

Any further ideas ?

Thanks !

New firmware solves bugs, which may matter.

One more thing I could think of is the port.

Go to the router’s wireguard settings, find out the detailed configuration and you will find a local port. Change that to anther one.


I finally got it to work !

@alzhao thanks you for your help, unfortunately the solutions you proposed did not work for me.

I continued browsing on the forum and it seems quite a few people are having issues with the PiVPN home hosted Wireguard servers and the GliNet devices.

The solution for me was to input the configuration manually, field by field.

  • I lowered the MTU to 1280 in my PiVPN config and generated a new client with the new MTU value.
  • I left out the IPv6 part of the allowed IPs.

So there seems to be an issue with how the Slate interprets the Wireguard config text, is this something you could look into @alzhao ?

Thanks anywyay and I hope this can help others !

1 Like

Can you send me the config file? You can mask the keys. I just need to verify the format.

Thank you, thank you, thank you. I had this exact issue on the new Slate AX (AXT1800). The solution is NOT to upload the config file, or copy & paste it. Instead, you need to go into into “Item Mode” and manually enter each field. It then works perfectly.

I think I have also worked out what the issue is with parsing the config.

For whatever reason, a manual copy/paste or file upload has its “PresharedKey” field stripped out. It only applies when using “Item Mode”. @alzhao Can you please verify if you see the same?

1 Like

@hilll can you follow this issue?

OK, i follow this issue.

I confirm the issue…

Thank you, the AXT1800 have new version, have resolved the problem skip “PresharedKey” field.
you can use the new version, as follow:


1 Like

That’s amazingly quick. Thank you!