Wireguard shows connected but NO INTERNET

Hello, I have 3 routers, two at different locations in my home city and one I carry where I travel. It seems that my Wireguard VPN connections have stopped providing internet since yesterday on both devices.

  1. The VPN does connect and it seems that I have internet for a split second on both connections but after it shows its connected BUT but the internet does not work.
  2. Soon after the initial connection, the log shows some firewall restart and then every 2 minutes the router tries to create ACTION=KEYPAIR-CREATED.

Below is the Logs…
Wed Sep 27 12:47:38 2023 user.notice mwan3[13230]: Starting tracker on interface wgclient (wgclient)
Wed Sep 27 12:47:41 2023 user.notice firewall: Reloading firewall due to ifup of wgclient (wgclient)
Wed Sep 27 12:49:38 2023 kern.info kernel: [ 2869.625548] wireguard: wireguard-hotplug IFNAME=wgclient ACTION=KEYPAIR-CREATED
Wed Sep 27 12:51:38 2023 kern.info kernel: [ 2990.358400] wireguard: wireguard-hotplug IFNAME=wgclient ACTION=KEYPAIR-CREATED
Wed Sep 27 12:53:39 2023 kern.info kernel: [ 3111.065145] wireguard: wireguard-hotplug IFNAME=wgclient ACTION=KEYPAIR-CREATED
Wed Sep 27 12:55:39 2023 kern.info kernel: [ 3231.258439] wireguard: wireguard-hotplug IFNAME=wgclient ACTION=KEYPAIR-CREATED

I have tried everything restarting the server, restarting the router, creating a new user on the server and using that new configuration to connect the route. I don’t know what could be causing this issue, and the most confusing part is that it happened to both of my connections (its possible my backup had the issue for a while I just didn’t notice it because I only use it as a backup). For now I connected to a completely separate VPN on a different device elsewhere so it is unlikely to be my client router that is causing the issue, it seems to be an issue with the server routers.

Could the routers at the home city locations have gotten a auto update?

How would that affect it if you don’t mind me asking? It seems that I am still running on the previous firmware if compile time refers to the last update time, and also there is an update available currently.

Sometimes with auto update and keep settings, the core packages are changed(or removed) and the saved settings messes up the config file. I have encountered this a couple of times and it is best to do a manual upgrade without keeping settings then load a config file later.

I wish it was that easy, it seems that an update did not occur, thank you for the suggestion though!

The same thing happened to me, about 2pm yesterday. Now I can no longer connect.

Here is an update if you are attempting to connect to AzireVPN. They are having server issues on their end. No ETA of when it will be working again.

1 Like

Have you figured out the solution? I talked with support she said it was my default DNS in the config, but I do not know how to adjust that plus I have DDNS setup. I responded to the answer but they have yet to get back too me.

I have a personal VPN so that does not apply here, but thank you for your input!

I’m just leaving this here so anybody who has the same issue can figure it out. Essentially the support team said that it was the default DNS even though I have DDNS set up and I can’t change the default DNS when configuring wire guard on my server router. I tried to get some more clarity but I did not receive any message so I just tried going into the wire guard configuration on my client routers and changing the to 8.8.8.8 from 64.6.64.6. Miraculously this solved the issue entirely why? I don’t know I don’t understand this interaction, I don’t know what’s going on if anyone does understand what’s going on here and can explain that would be amazing but nonetheless. I am leaving this here in case someone else has the same problem and wants to resolve it.