Wireguard stuck when rebooting MV-1000W

As the title says, why when rebooting MV-1000W is it unable to make an automatic VPN connection with Wireguard???

I’ve tried with Internet kill switch on or off, allow access local network work, whatever I do, Wireguard won’t connect from reboot or power cycle.

I’ve tried different Wireguard profiles also.

Sometime when it reboots the VPN icon colour is yellow, and fails, sometimes when it reboots the VPN icon colour is green and it still fails to connect to VPN.

Using 3.203

I have a similar problem with my GL-X300B, also running version 3.203.
After a power cycle, the VPN client is red and unable to connect. All I need to do is click Abort, then Connect, and it works.
I assume it’s some racing condition where the VPN tries to connect before the internet interface is up, and gives up.

@alzhao Could you comment please? Is this normal/expected behaviour?

If you are using wireguard, can you pls try the following to see if it fix?

uci set firewall.@defaults[0].flow_offloading='0'
uci set firewall.@defaults[0].flow_offloading_hw='0'
uci commit

You must reboot the router to let it take effect.

I guessed to SSH into router, and just pasted that code all together.
Rebooted router, and VPN started automatically! So it worked, can you share what that code does as I have no idea. And can you put the code into the next firmware for this router? Thanks very much.

1 Like

Seems wireguard is having a problem with kernel offloading. The above turns it off.

Is there a plan to include the fix in a firmware update for affected devices?

yes. We are working on 3.211 firmware

1 Like

hi @alzhao This workaround stopped working. Lost electricity in the whole house, when it came back everything came online again accept the Brume, couldnt access the Brume via goodcloud, power cycling the Brume remotely didn’t do anything, so had to VPN into my main home router, and access the Brume admin panel that way, click “Abort” on Wireguard page, then click “Connect”. I hope this is fixed in next firmware :pray:

Pls upgrade to 3.211 firmware and it should fixed the problem already.

The temporary fix is only part of the fix.


1 Like

This still isn’t fixed on 3.211.

Seems like quite a basic requirement for modem router using a VPN, if router loses power, then power comes back, router is able to automatically regain the Wireguard connection? Surely?

The problem is repeatable, each time the router is power cycled, Wireguard doesn’t reconnect, it tries and fails, I get orange icon, I have to manually go into the device admin, click “Abort”, wait 10 seconds, then click “Connect”.

@alzhao are you able to correct this behavior with a software update or it’s not possible?

I was able to replicate the same problem here. That is why I said it should have been fixed in 3.211.

As you said NO, I will investigate this problem again.

I’d like to confirm the exact setup. Pls confirm:

Model: MV1000W
Firmware: 3.211
Method to connect to Internet: cable or repeater? Pls specify
Wireguard provider: Pls provide

Yes, and I’ll pm you the details, thanks.

Thanks for fixing the Wireguard not restarting on reboot of Brume @alzhao

I have the same issue with GL-SFT1200.

Each time I click “reboot” Wireguard client doesnt startup again, it’s been like this for 6 months since I bought the router.
I update to latest firmware each time hoping it is fixed.
Using a VPN router, having the VPN survive a reboot is very important.

Please fix :pray:


As I don’t have this problem so it may be something specific.

Can we do this:

  1. Let me know the details of your upstream connection
  2. Maybe pm me the config to try directly.
1 Like

Thanks for getting back to me, I’ve just sent you my config now.
Curious what your results are. Please check your messages.

Got your message. Checking.

Have the same issue - WireGuard won’t properly connect upon reboot automatically on “GL-MT1300 / Beryl” with the latest firmware v3.215.

Using WireGuard client, kill-switch, vpn policies to disable for Guest Wi-Fi, use VPN for all processes, using custom DNS client which is behind the VPN (pi-hole).

@alzhao Do we have some news about this issue?

You managed to successfully fix the Beryl bug regarding the MAC clone (custom MAC addresses) last time. Actually, it seems to me you’ve fixed almost all the bugs. Good job, guys! :muscle:

Btw is this issue present also in GL-MT3000 (Beryl AX)? Thinking about ordering some newer GL.iNet routers once again. Thanks!

It is better to start a new thread.

Which wireguard you are using?
How do you connect to the Internet? cable, repeater, tethering?

@alzhao Thanks for reply. I will start a new thread if the issue is not fixed in the new firmware version as it seems it’s related to this thread (OP).

Anyway, here is my config which I’m using:

  • Wi-Fi repeater
  • WireGuard client
  • Internet Kill-switch
  • VPN policies to disable VPN for Guest Wi-Fi, use VPN for all processes, VPN enabled for all clients
  • custom DNS (pihole - local ip behind WireGuard), force all clients to use DNS server

Thank you.