Wireguard VPN just started saying password is wrong for wifi

I have been using StarVPN for VPN and Wireguard on Beryl AX. Has worked perfectly fine for weeks, until tonight.

On my laptop, the internet stopped working - checked the portal and everything was blue (Internet on and VPN on, looked perfect). I rebooted, and then I am getting the error saying that the password for the wifi network I am connecting to is wrong. This ended up somehow solving itself and now back to the status of internet and VPN blue/good, but I cannot access the internet from my laptop.

Has anyone else experienced this issue and/or know how to fix? thanks so much

What firmware version?

Execute the following commands on your laptop:

ping wg-server

I tried again this morning and everything was working with internet somehow. Then I updated to 4.2.3, and we are back on the issue of saying this issue:

“Connection failed, will retry later…
Could not find the network, please check the SSID and security type you entered.
While attempting to reconnect, your router will periodically scan for Wi-Fi networks, and your guest Wi-Fi network will be temporarily unavailable during this scan.”

Here are results of running the commands:


PING ( 56 data bytes

Request timeout for icmp_seq 0

Request timeout for icmp_seq 1

Request timeout for icmp_seq 2

ping: cannot resolve wg-server: Unknown host