Wireguard VPN server unrechable from smartphone

I set up a AR-750 as LAN to WAN router, which is The AR750 is connected through his wan port to the main router at his lan port.
I would like to reach my AR-750 network from my smartphone via Wireguard server.
So, i set up the WG server on the router and the WG client app on the smartphone with QR code.
Then I’ve opened the 22 port on the router (TCP-UDP) and I’ve enabled a rule in the port forwarding menu:
External zone : wireguard
Port: 51820
Internal IP:
internal ports : LAN
Internal port: 22
but I’m not able to reach my client on 192.168.8.x network.
I also tried to change the external port to 22, but no way…
Any idea ? Thank’s.

you stated there are 2 routers involved. you keep referring to “the router” perhaps using terms like router1 wan is connected to router2 lan. router2 wan is directly connect to the internet. then explaining your setup because there will need to be configuring on internet router.

any how if you gl-inet router is at

then on your main internet router you neet to port forward udp 51280 to port 51280

verify by making it a static lease.

go into wiregurd server settings on gl-router and verify port number.

Thank you so much !..

Why do you use port 22? It is for ssh.

For wireguard it is 51820, use this for both external port and internet port.

Also you need to state what is the IP of your main router and AR750. You cannot have both 192.168.8.x. I am not clear which router is

Also one important thing, the Wireguard APP on iphone is not good because it does not display the connection status. When you enable Wireguard it always show connected. But it is not connected at all.

@ rp201rp
I applyed your suggestions and now everything works well.
In this way, I opened the VPN through the internet router into my AR750 (UDP 51820).
Now I can reach my WG VPN server on the AR750 and I can use the SSH from my smartphone in order to reach every client in the network.
Thank you again.

Today my VPN from smartphon stopped working and it has no more started…neither the SSH through it.
Main Internet router has not been modified and UDP is always opened at 51820 on it to my AR750…And nothing else.
When I’m inside my LAN, I can use SSH with no problem. When I try to connect from remote, I’m not able to do it…from today (yesterday, yes…)

Can you try changing another port?

Maybe your ISP blocks your port 51820.