Wireguard VPN Tunnel starts and traffic stops within 10 minutes


I have purchased a GL.iNet AXT1800 Slate AX that I use as a client and a MT3000 BerylAX that I use as a server to my Residential IP address. I use wireguard as VPN. Here is my config:


Address =
ListenPort = 7619
PrivateKey = (redacted)
MTU = 1320


AllowedlPs =, :/0
Endpoint = (redacted).glddns.com:51820
PersistentKeepalive = 25
PublicKey = (redacted)

When I turn on the VPN, traffic starts and my devices IP address shows the one the server is using. The tunnel works for a varying amount of time, but within 2 to 10 minutes, no traffic goes by anymore and my client device is deprived of internet connection.

I’ve tried lowering the MTU to no avail.

Would you have any idea of how to troubleshoot this? Firmware is 4.5.0.

Thank you.

Remove this option, it should not exist if mt3000 firmware is version 4.5.
What’s the status of the VPN dashboard page when the issue happens?

I’ve removed the ListenPort option but so far it does not change anything.

The VPN dashboard page shows like this, the traffic exchanged does not increase anymore (it does not stay strictly constant but it only increases by a few bytes).

Thanks for your help.

I suggest you try a phone app or PC wireguard client, to determine if it’s the underlying network cutting off traffic.

I’ve tried plugging both the server and the router on three different ISPs each and it does the same thing so I doubt it’s an ISP issue.

All of my networks use IPv6 though, I read there could be problems arising from using DDNS on networks using IPv6. Would you know more?