Wireguard VPN unable to access network shares

I am trying to have my GL-AXT1800 act like a bridge to my home network. Basically I want it to connect to my homes network though wireguard and devices connected to the GLNET router will act as if they were at the home network without the need for a software client for vpn. Main goal = Able to access network devices for example is a NAS, file shares and browse the internet though the IP at home.

I have a Wireguard connection established on the GLNET and when I use the web, I show as accessing internet though the homes IP address. This means all internet traffic is passing through the tunnel, however if I attempt to access a network resource or network share at the home its unreachable and does not respond to pings.

If I use OpenVPN or Wireguard on my pc client everything functions fine so I know all is setup server wise on the wireguard server. However using wireguard or openvpn on the GLNET only internet works and expected with no network resources accessible or responding to pings.

Any ideas?

Few diagnostic stuff

Tracing route to over a maximum of 30 hops
1 2 ms 1 ms 1 ms console.gl-inet.com []
2 console.gl-inet.com [] reports: Destination protocol unreachable.


Please also enable the remote LAN access on server side

As displayed above, I did have that enabled on the glinet at the remote location. The server side is not a glinet server its a standard OPENVPN server. I also tried wireguard with the same results. If I use the PC client I am able to access the network shares.

This may or may not be applicable to your situation but I’ll post it just in case.

I was connecting via WireGuard to my home LAN and was not able to access shared drives on my LAN. The issue was with the Windows firewall on the machine hosting my shares. I had to go into the windows advanced firewall settings change my windows firewall rule for port 445 [File and Printer Sharing (SMB-in)]. This is normally set for Local subnet only, so it will block anything from the VPN as it does not have a local IP address. You can add your VPN’s subnet address to the firewall rule’s Scope.

Thanks for reaching out.

I am able to access network shares however device specific will not work. For example a devices web gui at cant access through a vpn connection, however using the software openvpn client it will.

Hi, I’m experiencing the same issue with a similar setup. Did you manage to solve it?

Tech support was great.

Turns out it was a IP address issue. I believe the Gl-iNet router was on a different IP range also.

Basically since it was connected to a router (Orbi) which was using the range. Once I changed the router it was connected (Orbi) to the range the VPN and networking worked.