Wireguard was working all okay but suddenly no internet for me and my friend

So, the following points describe my situation:

  • Have been using wireguard for a long time, everything was okay
  • suddenly today there is NO Internet(even though client can connect to server), I didn’t change anything whatsoever.
  • This happened for me and my friend whose server routers are in the same building (different connections but same ISP Bell Canada)
  • Internet was working today but did behave fishy for a while. It was not working briefly, and my smart speaker disconnected and connected 3-4 times. Now server INTERNET is working perfectly okay, but unable to access internet from client. :frowning:
  • I tried to change the port from 51820 to 821 and IP from 10.0.0.1 to 10.20.0.1 but it still the same behavior (Connection to server is established which I could verify in client and server GL INET but NO INTERNET).

I have Convexa as server and Beryl and Mango as client routers.

[Interface]
Address = 10.20.0.2/32
ListenPort = 4565
PrivateKey = OJ1QLMZYn…
DNS = 64.6.64.6

[Peer]
AllowedIPs = 0.0.0.0/0,::/0
Endpoint = 76.71.158.23:821
PersistentKeepalive = 25
PublicKey = p9b8cRHLDT…

I use the connection established as the primary way to verify everything is working.

What bothers me is this is something strange for first time in almost a year and a half .
Pls help me GL-INET, I have to work.

First, use the exact wireguard config as the router and try that in your pc to see if it connects.
If cannot, then it is problem of server side.
If connect, then it is problem of client side.

Second, if it is problem of client side, pls make sure you upgrade the firmware of Beryl.

General issues related to server side:

  • IP changed
  • ISP blocks port

General issues related to server side:

  • Listen port is blocked. The new firmware removes the listen port

The same thing happened to me, starting at about 2pm (Sept 27th) yesterday. I use Wireguard to connect to AzireVPN and it has worked great for eight months. Yesterday it stopped working.

If you are attempting to connect to AzireVPN. They are having server issues on their end. No ETA of when it will be working again.

One of the guys told me he fixed a similar problem by changing the DNS as the current one seems unresponsive. I didn’t find a place in the ui where I can update DNS. I am using version 3. Is it possible in version 4 inly?

DNS in v3 is in more settings->custom dns
DNS in v4 is in network->dns

2 Likes