Wireguard works on every wifi network except Comcast/Xfinity free wifi

I have the following setup - GL Inet’s Brume device behind home router which acts as openVPN server and Wireguard Server - GL Inet’s Beryl device that is acting as a client for the server’s above

To test the VPN, I connected one of Beryl device to Xfinity hotspot (one without password). I have no issues with using OpenVPN. I can access internal and external sites. However, with wireguard, I just can’t access anything

To rule out the configuration issues, I have connected my mobile to cellular data and used the wireguard client with the same configuration that I have used in the Beryl router. And this time, I can access both the internal and external sites using OpenVPN and Wireguard

Are they any ways to mitigate these issues. Does changing the port for wireguard server help ?

1 Like

Can you edit the listenport of the Wireguard config on Beryl and try?

Some isp may blocks some ports.

When I first set up WireGuard on my Creta using Xfinity Wi-Fi I had no data. Using the web browser interface I noticed that the MTU field was blank. Once I entered a value of 1320 (or maybe it was 1340) the data started working.


Thanks @doczenith1 . I can try this as well. Have you edited the MTU on the client side only or on the server side while creating the key (& then loading that on client)

I tired with 52920 port and noticed the traffic didn’t go through even with this new port

I tried with 1320 and it worked. Thanks a ton @doczenith1


The Creta is a client. The server is on my Asus router. The Creta is the only client that I needed to enter a MTU value on. My Android phone clients have no MTU value entered.