Wireless security/encryption not shown in luci (Flint GL-AX1800)

Hello,
I’ve just received my Flint AP and I’ve started to play with it, as I’m going to have 3 SSID on different vlans from my main router, I’ll have to configure it mostly with luci.

On the main web gui the wireless security is enabled:


And I can choose between the different WPA2/3&co options:

If i then go to luci it seems that there is no encryption enabled:


and I can’t event set it to WPA2 or 3:

There are the relevant config files:

root@GL-AX1800:~# cat /etc/config/wireless
config wifi-device ‘wifi0’
option type ‘qcawificfg80211’
option channel ‘auto’
option hwmode ‘11axa’
option disabled ‘0’
option band ‘5G’
option noscan ‘0’
option htmode ‘VHT80’
option txpower ‘28’
option txpower_max ‘28’
option country ‘US’
option macaddr ‘94:83:c4:12:12:11’

config wifi-iface
option device ‘wifi0’
option network ‘lan’
option mode ‘ap’
option encryption ‘psk2’
option disassoc_low_ack ‘0’
option wds ‘1’
option ifname ‘ath0’
option athnewind ‘1’
option blockdfschan ‘1’
option disablecoext ‘1’
option ssid ‘AX’
option key ‘*****’
option disabled ‘0’

config wifi-device ‘wifi1’
option type ‘qcawificfg80211’
option channel ‘auto’
option hwmode ‘11axg’
option disabled ‘0’
option band ‘2G’
option noscan ‘0’
option htmode ‘HT40’
option txpower ‘28’
option txpower_max ‘28’
option country ‘US’
option macaddr ‘94:83:c4:12:12:12’

config wifi-iface
option device ‘wifi1’
option network ‘lan’
option mode ‘ap’
option encryption ‘psk2’
option wds ‘1’
option disassoc_low_ack ‘0’
option ifname ‘ath1’
option athnewind ‘1’
option blockdfschan ‘1’
option disablecoext ‘1’
option ssid ‘AX’
option key ‘*****’
option disabled ‘0’

config wifi-iface ‘guest5g’
option device ‘wifi0’
option network ‘guest’
option mode ‘ap’
option wds ‘1’
option ssid ‘GL-AX1800-20f-Guest-5G’
option encryption ‘psk2’
option key ‘goodlife’
option ifname ‘ath2’
option disabled ‘1’
option guest ‘1’
option blockdfschan ‘1’
option disassoc_low_ack ‘0’
option flag ‘1’

config wifi-iface ‘guest2g’
option device ‘wifi1’
option network ‘guest’
option mode ‘ap’
option wds ‘1’
option ssid ‘GL-AX1800-20f-Guest’
option encryption ‘psk2’
option key ‘goodlife’
option ifname ‘ath3’
option disabled ‘1’
option guest ‘1’
option blockdfschan ‘1’
option disassoc_low_ack ‘0’
option flag ‘1’

root@GL-AX1800:~# cat /var/run/hostapd-ath0.conf
driver=nl80211
interface=ath0
logger_syslog=127
logger_syslog_level=2
logger_stdout=127
logger_stdout_level=2
channel=auto
ieee80211n=1
ieee80211ac=1
ht_capab=[LDPC][SMPS-DYNAMIC][TX-STBC][RX-STBC-1][MAX-AMSDU-7935][DSSS_CCK-40]
vht_capab=[MAX-MPDU-11454][RXLDPC][SHORT-GI-80][TX-STBC-2BY1][RX-STBC1][SU-BEAMFORMER][SOUNDING-DIMENSION-2][SU-BEAMFORMEE][MAX-A-MPDU-LEN-EXP7][MU-BEAMFORMER][RX-ANTENNA-PATTERN][TX-ANTENNA-PATTERN]
hw_mode=a
wmm_enabled=1
dtim_period=1
ignore_broadcast_ssid=0
ctrl_interface=/var/run/hostapd-wifi0
send_probe_response=0
wpa_passphrase=****
auth_algs=1
wpa=2
wpa_pairwise=CCMP CCMP-256
ssid=AX
bridge=br-lan
ieee80211w=0
wpa_key_mgmt=WPA-PSK

root@GL-AX1800:~# cat /var/run/hostapd-ath1.conf
driver=nl80211
interface=ath1
logger_syslog=127
logger_syslog_level=2
logger_stdout=127
logger_stdout_level=2
channel=auto
ieee80211n=1
ieee80211ac=1
ht_capab=[LDPC][SMPS-DYNAMIC][TX-STBC][RX-STBC-1][MAX-AMSDU-7935][DSSS_CCK-40] [SHORT-GI-40]
vht_capab=[MAX-MPDU-11454][RXLDPC][TX-STBC-2BY1][RX-STBC1][SU-BEAMFORMER][SOUNDING-DIMENSION-2][SU-BEAMFORMEE][BF-ANTENNA-2][MAX-A-MPDU-LEN-EXP7][MU-BEAMFORMER][RX-ANTENNA-PATTERN][TX-ANTENNA-PATTERN]
hw_mode=g
wmm_enabled=1
dtim_period=1
ignore_broadcast_ssid=0
ctrl_interface=/var/run/hostapd-wifi1
send_probe_response=0
wpa_passphrase=****
auth_algs=1
wpa=2
wpa_pairwise=CCMP CCMP-256
ssid=AX
bridge=br-lan
ieee80211w=0
wpa_key_mgmt=WPA-PSK

From stock config I only did these changes:

  • Init Wifi with SSID “AX”
  • Set network mode to Access Point
  • Enabled luci

I got the same result with stock firmware 3.205 and now I’m ruinning qsdk-ax1800-3.206-1008.img

Thanks

Luci may not be fully compatible.

Can you check the encryption by connecting to the SSID?