WLAN connection using VPN

Hi community,

I am using my GL-AXT1800 with the Surfshark OpenVPN client.
I configured it to use a static IP.
The current router setting is "Network Provider Router" ---(ethernet)---"Slate Router"---(ethernet)---"Personal devcices".

The vpn works well when I connect a laptop with a ethernet cable.
However, when I connect my phone via wifi to the slate router, the phone doesn't seem to go through the vpn. For example, when I check my current location while connecting to the Slate's wifi, it shows an actual location not the vpn server location.

Is there an additional setting that I have to configure to enable the vpn for the WLAN?

Please check your VPN policy, it should be "Global" in your case:

Thanks for the reply, but it has been already set as "Global Proxy".
Still same issue happens with it.

How do you check your location?

I am checking it from websites, like https://iplocation.io/

Does your IP address change when trying it on those websites?

No, they are same with the ip address

Are you sure that they use the Wi-Fi of the GL.iNet router? Maybe it's the same name like the upper router?

Your laptop (cable) and your wifi devices (wireless connectivity) under the AXT-1800, they are same in the LAN, so please check your wireless device if are they connected to the AXT1800 wifi?

I am sure since the Wi-Fi name is starting from "GL-AXT-...". I am using different name for the upper router.

As mentioned above, I am using the one from the AXT1800.

  1. May I know is the IP of the LAN (Ethernet wired cable, laptop) and WLAN (Wi-Fi, phone) on the same LAN segment?
  2. May I know did you enable the VPN Policy feature of the Slate? And probably in the policy, permit the laptop access the VPN or deny the phone?

For 1, I am not sure how I can check it, but I guess they are. When I am checking the connected clients, both LAN and WLAN devices are having the identical numbers for the first three parts. e.g "NNN.NNN.N.133" for LAN device and "NNN.NNN.N.166".

For 2, the current VPN policy is set to "Global Proxy" saying all trafic goes through VPN.

Ok, I somehow got the reason. It was because of the iCloud Private Relay function setting the location depending on the system's time zone. So it was not a router's problem! Still, thanks for the support and hope this thread could help someone in the future..

2 Likes