Wrong image

My new Beryl router shows an image when the vpn connection is on, this not ok The function is opposite.

This means the physical button on the router

It is settings for Mode Switch.

Sorry maby I didn’t explain it well enough. Look at the pictures. You sample is different then the reality. So my vpn is on when your sample say it is off.

1 Like

It looks to be correct to me? It says if its on the left then your VPN will be on and if its to the right it will be off. Your photo shows the button being in the left position and the VPN shows as being on? To my understanding that is correct functionality. If I’m still misunderstanding then maybe see if the drop down box has an option saying off/on instead of on/off

Thanks for your feedback. We will fix it.

No, he’s right. The question has nothing to do with whether the switch is on the left or the right.
Notice the dot next to the switch. When the switch is near the dot, the VPN should turn off, but it doesn’t.
In other words, the dot on the page image should be to the right of the switch.


Hey Yuxin,

Happy new year, I am pleased you noticed. I have a kreta router from GL.Inet as well and therefore I know.

I have one question more, is there a sollution for creating a network behind a captive portal in a hotel?

Thanks a lot,


Happy new year, the solutions in this document should be able to handle most cases.
Connect to a Hotspot with a Captive Portal - GL.iNet Docs (gl-inet.com)