Wrong Key Repeater error

I am having the same “Wrong Key” problem. It was working fine connecting wirelessly via repeater to my home wifi. but yesterday it stopped working. It stopped working the day before because of internet issues but I was able to reconnect MT1300 to the wifi again. I left the house, came back later that day. The wifi was working but the mt1300 internet wasn’t working. I went into the admin panel, tried to reconnect to the wifi, it wouldn’t do it. I reset the device (short and long), updated the firmware to the latest version 3.215, and it still says, “Wrong Key” when I try to connect to the wifi. I brought it to my friend’s house, connected the mt1300 to her router via ethernet. The internet worked. I tried to connect to the wifi via repeater with it connected to the router via ethernet and without it connected to the router via ethernet. It didn’t work. So, this isn’t just my internet, it is happening with other wifi connections too. I can’t connect the MT1300 to my home router because my roommate is a jerk. I need help! It has to be connected wirelessly and I need the VPN on the MT1300 for work. I can’t just connect regular.


Depending on how desperate you are, you might try the 4.0 beta (this might be a one-way door though - at least without doing u-boot).

Alternatively, you might try a stock build (I’d stay with 21.02.5 at the moment due to nftables/iptables issues), which uses a different (open source) wireless driver. You can use the travelmate package (and luci-app-travelmate) to automate setting up/connecting to wireless networks.

I’m very desperate. But, I’m worried about installing a firmware version other than the official release and then running into more problems like not being able to access the admin panel at all. I thought about installing a prior version but it said I could break the router if I did that so I stopped. The luci app travelmate sounds interesting. Can you give me instructions to do that?

I wouldn’t do travelmate on top of gl-inet’s firmware - too many duplicate functions going on. I use it frequently with stock OpenWRT on GL-iNet devices (including the MT1300) though.

Read this:

If you feel like you could do that if you had to, you’ll always be able to go back to stock firmware.

If you think you’re ok with that, and you’d like to try the OpenWRT/travelmate route then yes, I’ll write something up for you.

Upgrading to 4.1 fixed the problem as reported in another post.

1 Like

Didn’t realize you guys had gone to the mt76 driver in 4.0 or I would have suggested that more strongly.