X-750 V2 ethernet network switch problem

Hi has anyone had a problem connecting an ethernet switch? I want to connect more hard wired assets to my router but the router doesn’t see them or even the switch itself.
Ive tried two different branded switches and both won’t work and I’ve even tried different cables - so does anyone know what Im doing wrong or is the X-750 just not capable of doing this?
Ive even tried using an old router attached to the X-750 with the same cables and that is shown and i would just use that but for some reason the X-750 seems to stop me loading up the old routers set up page so that I can change settings etc.
This router is getting to be the worst item i have purchased as nothing seems straight forward with it as it doesn’t behave like a normal router it should be so simple adding a switch but Ive never had a router not see it before!
Any help would be gratefully received

Could this be a hardware issue? I have recently purchased the Shadow model which had a completely dead LAN port although WAN and wireless worked perfectly normally. Returned it for a replacement which has been working absolutely fine.

Thanks for the reply, strange thing is if I put say the tv Ethernet cable in the lab port in its own it’s recognised! But an Ethernet switch isn’t, tbh it’s driving me crazy as a lab port should work with either an Ethernet switch or whatever is plugged into it.
But I will keep your idea in mind as it’s obviously not working as it should!

Does the switch detect the router connection? maybe some switches do have problems, from what you described. I never heard this though

No for some reason if I say plug something in on it’s own it has full Ethernet and it’s seen by the router and given an ip, if I plug an Ethernet switch I’ve tried three different brands now the router didn’t give any an IP address and I get no traffic signals on the Ethernet switch it just shows it’s socket is being used!
It should by rights just see it and work but it doesn’t !

1 Like