X3000 failover not working

X3000 with firmware beta compiled 2023-10-27. Using cellular modem and Ethernet 1. When eth1 loses Internet there is no internet available even though cellular is connected and active. Doesn’t seem to matter if eth1 is priority 1 or if cellular is priority 1. Even with cellular as priority 1 there is no internet available if eth1 loses internet. I have reboot the router to no effect. If I disconnect eth1 cable then cellular works no problem.

Not that this is going to be helpful, but… I’ve got an X3000 with a cell modem and ethernet sources as well and failover when ethernet drops out works fine (as does recovery when ethernet restores connection to the internet); no physical disconnecting or reconnecting ethernet cables and no rebooting required. Failover time is generally <5s and never more than 20s. I’m on latest stable (4.0-release50402).

Hopefully stable will be updated soon. I would really like carrier (operator) locking.

1 Like

I just updated to the latest stable 0403 release 7 dated 11-15 and failover still not working. No matter what order of priority I set in the list as long as ethernet is connected it takes priority. Even if I set cellular to priority 1 and set eth to priority 5 it will not switch to cellular until I disconnect the eth. As soon as I reconnect eth it switches from cellular to eth. When eth fails and no internet is available I just get stuck with no internet, it will not switch failover to cellular at all no matter what, unless I unplug the eth cable. Something is not right and it sure would be nice to get a response from customer support.

I have verified thru luci app that the network policy changes are taking effect, and the mwan3 service is restarting on policy changes, but wan is still priority no matter what the policy is set to and if the wan interface loses internet the router is not switching to cellular. If I set policy to prioritize cellular as #1, the policy changes update in luci and the mwan3 service restarts, but wan is still prioritized and not cellular.

Here’s a thought: On your upstream ethernet connection (not on your X3000, but instead on whatever equipment you have on your ethernet side), do you have a DNS overrides/DNS Rebinding? Because, by default, your X3000 will ping,, etc… which are DNS servers. If your upstream equipment has a DNS override which redirects queries to encrypted DNS, it’ll be responding to pings to,, etc despite no internet connection.

As a quick test, when your ethernet connection is down, you can SSH into your X3000 and ping or ping - if you get a response, then its likely some sort of DNS override on the ethernet modem in your house. The solution would be to change the IPv4 Track IPs on your X3000 (just for the ethernet connection) to a server that isn’t a DNS server - something like google.com (

1 Like

Nah, this shouldn’t be the case since ping (ICMP) is not DNS (UDP/53). They won’t rewrite it.

That still would not explain why Ethernet retains top priority for Internet connection no matter what priority it is set to. I can set Ethernet to priority 5 and cellular to priority 1 and it stays on Ethernet.

Mine seems to work fine when eth goes down. However, after this latest update (0403release7) (and reset)… I can’t seem to get sim failover to work in either of mine. Will have to test at another place to see if it’s tower issues causing chaos.

Just to confirm - do you have “Forced Refresh Streams” enabled? And, are you giving the switchover ample time to detect a fail (3 pings five seconds apart = 15 seconds), and has the router had ample time to detect an active connection (8 pings five seconds apart = 40 seconds). And: Have you made any changes to the “Interface Status Tracking Method” for ethernet or cellular?

Yes, yes, yes, and no.