X3000 signal bar for modem not working

The router X3000 is working fine but there is no display for the cellular modem LED
I have 5GSA connection
The LED for power, internet, 2.4G wifi and 5GHz wifi is working
Is there a modem.sh call that is turning it off?
Maybe other reason?

Did you reinstall the gl-sdk4-modem ipk?

where may i download it from?

Last time, I gave you an ipk to fix the modem traffic inversion problem

Ok, i have that ipk
It didn't fix the traffic inversion problem.
But let me install it again

No need to install again
try this

Does this ipk not fix the traffic inversion issue?
look at


Unfortunately, it didn't fix the issue...
Above shows the current status after trying the new ipk

To summarize, here's what i tried.
#opkg update
#opkg --force-reinstall install gl-sdk4-modem_git.2024.106.25196-10a9cdl-1_aarch64_cortex-a53.ipk
#cp /rom/etc/uci-defaults/99-set_modem.sh /etc/uci-defaults/
#/etc/init.d/modem restart

Then the modem only connects to 4G+
So i try 5GSA commands for modem

The modem now connects at 5GSA
I refresh the webpage

Same traffic issue
The cellular modem LED is off now

What is the module version number?

Not sure i understand the question
The firmware is v4.0

I tested the light and it worked

Please let me know the results of these commands


Note, i am using a RM521F modem
So, this was edited: /lib/functions/modem.sh
/ RM520NGL|
Change this to :
Modem is now recognized as RM521F and works great.
So perhaps, gl-sdk4-modem_git.2024.xyz.ipk needs to have the above information.

Here are the responses -
AT+QGMR = RM521FGLEAR05A02M4G_01.200.01.200
AT+QGDNRCNT? = +QGDNRCNT: 1646136024,9741506294
AT+QGDCNT? = +QGDCNT: 713117,1338252

Still doesn't work, after running the above changes again


gl-sdk4-modem_git-2024.156.32563-2f5ac8b-1_aarch64_cortex-a53.zip (400.2 KB)
Try this ipk

opkg --force-reinstall install  /tmp/gl-sdk4-modem-xxxxxxxxxxxxxxxxxxxxxxxxxx

About the light not working
Please check whether the process exists

ps | grep modem
/etc/init.d/modem_signal restart

This is now working.
a. Traffic is reported correctly
b. Modem LED is lit

Some changes i made (only for my situation):-

a. From the ipk file (above), i edited /lib/functions/modem.sh
to :
Otherwise it only connects at 4G+
After the above change, it connects at 5GSA during bootup
Now it reports, traffic correctly.

b. I am running haproxy on port 443,80 as a load balancer and as a reverse proxy
(I could have use nginx for this but during upgrades that would get wiped. So
i decided to keep it separate using haproxy and it works great)

Since i had to move nginx to port 81 and 4431, i needed to edit

Change the line from
/etc/init.d/modem_signal restart

Now modem LED works again.

Everything works after reboot.

Thank you