X3000 - SIM locked issue without PIN on SIM card

I just received my Spitz AX GL-X3000 and tried with the Movistar SIM card I was using for two years in my previous 4G router without issues.
The SIM card is not PIN locked (no PIN) and I get the “SIM locked error” when used in the Spitz.
I left the PIN field blank in the router settings as I don’t see an option for unlocked SIM.
I tested with two previous firmware versions, with the last beta, putting the SIM in the second tray, resetting the router… I tested again the SIM in the old router and it works fine without PIN issues an connect to cellular network.
What can I do? Any suggestion?

Insert the sim, reboot the modem and share the logs after the error pops up. The logs can be exported as tar file.


Thank you for your reply.
Attached is the log after reset.


logread.tar (173 KB)

I see in the logs, a weird IP being assigned to your modem by your ISP:

daemon.notice netifd: wwan (8626): udhcpc: sending select for

What IP are you getting when you insert the SIM in the other working modem/phone?

Please do the following:

  • Log in into the GL web interface - > Network - > Multi-WAN
  • Click on the Options of the Cellular interface and disable it.
  • Now go back to the Internet page, reinsert the SIM correctly (either slot 1 or 2) and clcik Auto Setup.

Wit a little, if the connection is not established, please re-enable it with the following settings:

And then click Auto Setup. See if you can get connected to your ISP.

Thank you for your help.

The IP you mention is assigned by my home router as I have the AX3000 also configured as repeater to get access to the Internet for the upgrade, etc.

I will test what you suggest later today.

Two questions:

  • Do you know if the AX3000 support a SIM card without PIN set?
  • The Quectel modem version I have is RM520NGLAAR01A07M4G. The last versions in the repository are more recent. Should I update it to a more recent version?

Thanks again!

You should’ve mentioned in your first post as the troubleshooting procedures are different! You must first troubleshoot the SIM connection without connecting it to your home router!!

1 Like


Your are only behind by one version- i have not noticed any performance or features improvements in the latest. So I would advice not to.

1 Like


I made a full reset and the complete setup procedure to start with a clean router.
Additionally I used a new SIM card from Movistar operator with PIN code.
The result is the same as using the other SIM…

It doesn’t connect and I get every time the same “SIM locked” error message.

Attached is the log file with only the cellular configuration.

Thank you again.

logread 3.tar (184 KB)


I just got it working after downgrading to v. 4.4.3.
Now it’s working, I think I should do more tests to fine-tune the configuration.

Thank you for your help!

If others are getting similar issues, these are my tests for this issue and current solution:

  • Using a Movistar SIM card without PIN
  • Using a Movistar SIM card with PIN set.
  • X3000 firmware 4.4.6
  • System says “SIM locked” and not work with my SIM cards with or without PIN.

After many tests I found these cards connects and seems to work fine with firmware 4.4.3.
Tested with 4.4.4, 4.4.5 and 4.4.6 with no luck.
I think something happens with versions newer than 4.4.3. I don’t know what’s the cause of this issue and how it can be solved.

Probably more tests are needed for upcoming firmware versions with this kind of SIM cards. I can do more tests, even with beta firmware, if the developers need to do tests.


I agree with you some ISPs have issues with GL’s different firmware versions. Glad it worked!

Thanks for your detailed test. I confirm that it is a bug we introduced when solving another issue related to another carrier.

We will push 4.4.8 this week.

1 Like

I’m very sorry, after 4.4.3 did introduce this bug.

This week we will be releasing version 4.4.8 to fix this issue.

Thank you very much for your feedback!

1 Like

Thank you!
I’m available for testing if you need it.
Glad to see your first class support!

Looking forward for the new version. I’m available for testing if needed.
Thank you for your support!