X750 - 4G "connected", good IP etc. but does not route LAN traffic


#1

A few days ago I posted https://bugs.gl-inet.com/view.php?id=199 on the bug tracker; no responses yet.

There are many posts here, on forum.openwrt.org and elsewhere about this and similar issues - modem connects but no internet connectivity. I’m not sure if this is a bug in qmi or elsewhere in openwrt, or a problem in the gl-inet factory config. But I’m sure there are many others struggling with this problem.

Any and all suggestions and pointers welcome, for me and others!

Thanks
Sean


#2

Does your carrier allow for data sharing? Would a change in mtu help?


#3

I have used many routers (MIFI, iphones, others) on Vodafone UK, so yes, it allows data sharing. How would i change mtu? Also, an mtu of 1500 is correct, isn’t it? And services like dns don’t use messages much shorter than 1500 bytes to I’d expect them to work if that were the problem.

BTW ny network config is:
config interface ‘modem_1_1_2’
option ifname ‘wwan0’
option service ‘fdd_lte’
option apn ‘Internet’
option proto ‘qmi’
option device ‘/dev/cdc-wdm0’
option username ‘web’
option password ‘web’
option metric ‘40’
option disabled ‘0’

Thanks
Sean


#4

Hello,Sean

Can you describe how the problem came about? I remember dealing with the problem.
In case of a problem, you can use ifstatus modem_1_1_2_4 to check the status and see if the IP address is the same as the you using uqmi -d /dev/cdc-wdm0 --get-current-settings

Thanks
Luo


#5

Thanks Luo. They look the same to me:

root@GL-X750:~# ifstatus modem_1_1_2_4
{
“up”: true,
“pending”: false,
“available”: true,
“autostart”: true,
“dynamic”: true,
“uptime”: 100,
“l3_device”: “wwan0”,
“proto”: “dhcp”,
“device”: “wwan0”,
“updated”: [
“addresses”,
“routes”,
“data”
],
“metric”: 40,
“dns_metric”: 0,
“delegation”: true,
“ipv4-address”: [
{
“address”: “10.22.154.7”,
“mask”: 28
}
],
“ipv6-address”: [

],
"ipv6-prefix": [
	
],
"ipv6-prefix-assignment": [
	
],
"route": [
	{
		"target": "0.0.0.0",
		"mask": 0,
		"nexthop": "10.22.154.8",
		"source": "10.22.154.7\/32"
	}
],
"dns-server": [
	
],
"dns-search": [
	
],
"inactive": {
	"ipv4-address": [
		
	],
	"ipv6-address": [
		
	],
	"route": [
		
	],
	"dns-server": [
		
	],
	"dns-search": [
		
	]
},
"data": {
	"hostname": "GL-X750",
	"leasetime": 7200
}

}
root@GL-X750:~# uqmi -d /dev/cdc-wdm0 --get-current-settings
{
“pdp-type”: “ipv4”,
“ip-family”: “ipv4”,
“mtu”: 1500,
“ipv4”: {
“ip”: “10.22.154.7”,
“gateway”: “10.22.154.8”,
“subnet”: “255.255.255.240”
},
“ipv6”: {

},
"domain-names": {
	
}

}
root@GL-X750:~#


#6

I think it’s also worth noting that the modem is sending data but receiving almost nothing:

Protocol: Unmanaged
Uptime: 0h 10m 27s
MAC-Address: 06:EE:4A:EF:FF:6F
RX: 610 B (2 Pkts.)
TX: 36.91 KB (433 Pkts.)

Actually the modem may be receiving data on the 4G side but isn’t forwarding it over IP into the router.


#7

This situation is different from what I’ve seen before. Are you sure your firewall allows modem access to the Internet?
You can try manual dialing and use ttyUSB3 to see if the problem still exists.
Can you see /etc/config/firewall


#8

I have been doing a factory reset between each set of tests, and I have not touched the firewall settings.

Here is a zipped archive of /etc/config/firewall: firewall.zip (919 Bytes)

Also, if there was a firewall issues I would expect to see data passing from the modem to the router but no further. As noted earlier, effectively no data appears to be coming from the modem.

I will try ttyUSB3 as you suggest.

Thanks


#9

Aha! Using either /dev/ttyUSB2 or /dev/ttyUSB3 seems to work. Immediate connection, routing traffic as expected.

So I guess this is related to qmi? It seems that a factory reset and then booting with a Vodafone sim installed ends up with the modem configured to use /dev/cdc-wdm0 and not /dev/ttyUSB3

If I can do anything more to help diagnose or investigate further then just let me know.

Cheers
Sean


#10

emmm,Is this a problem that comes up every time you use QMI?
This is the first time I have come across this problem
What is your modem model?
Can I have a look at it remotely?


#11

Modem is an EP06.

I guess you just need an ssh session to take a look remotely; I can’t that up right now but I’ll try over the weekend. Can you give me an email address or some other way to send you credentials?

BTW, another complication: once the modem worked I installed the various packages I want to use, including luci-proto-qmi for testing in the future. After the next reboot the router came up using /dev/cdc-wdm0 to connect, and routed successfully. In order to confirm this, and especially to see if it’s the installation of luci-proto-qmi that makes the difference, I guess I will need to do ANOTHER factory reset, installs, etc. Another reason to leave to the weekend.


#12

louchongjun@gl-inet.com is my email address.
Thanks
Luo