X750 deBrick installed wrong firmware, wont reset

so My kid tried to install rOOTer firmware… then the Router wouldnt work… Kids

after searching here we found the reason DEBrick wouldnt work, needed the link… uboot.html added to IP address

well then he uploaded the wrong firmware, ar750 instead of x750

Now just the 2G and LTE light are lit and it wont reset per the Debrick via Uboot - GL.iNet Docs

any ideas folks



UBoot should definitely work if you’re doing it correctly. Make sure you set you computer lan adapter as described. I also run a constant ping from windows command terminal to see when to release the reset button. Much easier than relying on the the lights flashing. Release as soon as it starts communicating. The constant ping command is: ping -t

Also, don’t for get to set the adapter back to automatic after the flash takes and try connecting by default address if loading the GL.net firmware. I have also had to clear my browser cache sometimes.

But it just sits with the Last 2 lights ONLY on.

wont reset or anything.

any way to hard reset it again?

So you pressed and held the reset button in and waited for it to communicate then released using the terminal command I gave? It never showed replying, only showed no response?

Also, you have to remove power, then plug in while holding reset in, it is bit tricky.

I did… tried the reset a few Times

its froze on the 2G and LTE lights only. the Power or others dont come on now, reset or not…

Im stuck on what to do now

when I do the power off hold reset, then power on, it does nothing… no blinking at all

If that ping never comes back with a response then I don’s know what to do, it may be totally locked up. Again, verify your computer adapter is set correctly and doing that constant ping before you start. If you still can’t get in then I don’t have anything further to try, sorry.

appreciate the help

I emailed GL-Inet to, we shall see

worst case ill send it back and get a freshy one

PS: No help now but in the future if ever jumping between different variants of firmware never use the built in UI, only use the recovery/debrick method to install. Good luck, hope you get it going again.


If you flashed anything in uboot.html, you bricked the router completely.

You can only flash the correct uboot there.


alzhao, I didn’t catch that in the OP. That is definitely not good!

1 Like

If you don’t have a flash programmer maybe you can send to us to repair.

1 Like