x750-EC25AF - SIM card not registered


I have a brand new x750 using the EC25AF modem, with a Tmobile sim card and I’m getting the error: SIM card not registered.

I have tested this sim card in a phone, and it is working as expected. I have tested the same sim card in another device, and it is working as expected.

Is there anything I can try to get this to connect?

Revision: EC25AFAR05A06M4G


+QNWINFO: "FDD LTE","311490","LTE BAND 12",5035

+QCFG: "band",0x260,0x800,0x0

+QCFG: "nwscanmode",0

+QCFG: "gprsattach",(0,1)
+QCFG: "nwscanmode",(0-8),(0,1)
+QCFG: "nwscanseq",(00-0102030405),(0,1)
+QCFG: "servicedomain",(0,1,2),(0,1)
+QCFG: "roamservice",(1,2,255),(0,1)
+QCFG: "band",(0-200),(0-7FFFFFFFFFFFFFFF),(0-7FFFFFFFFFFFFFFF),(0,1)
+QCFG: "rrc",(0-4)
+QCFG: "cops_no_mode_change",(0-1)
+QCFG: "urc_cause_support",(0-31)
+QCFG: "msc",(0-2)
+QCFG: "sgsn",(0-2)
+QCFG: "hsdpacat",(6,8,10-24)
+QCFG: "hsupacat",(5,6)
+QCFG: "pdp/duplicatechk",(0,1)
+QCFG: "tdscsq",(0,1)
+QCFG: "airplanecontrol",(0,1)
+QCFG: "ledmode",(0-2)
+QCFG: "ehrpd",(0,7)
+QCFG: "usbid",<vid>,<pid>
+QCFG: "usbee",<enable>
+QCFG: "usbnet",<0-2>
+QCFG: "usbcfg",<vid>,<pid>,<diag>,<nmea>,<at_port>,<modem>,<rmnet>,<adb>,<uac>
+QCFG: "urc/ri/ring",("off","pulse","always","auto","wave"),(1-2000),(1-10000),(1-10000),("off","on"),(1-5)
+QCFG: "urc/ri/smsincoming",("off","pulse","always"),(1-2000),(1-5)
+QCFG: "urc/ri/other",("off","pulse"),(1-2000),(1-5)
+QCFG: "risignaltype",("respective","physical")
+QCFG: "urc/delay",(0,1)
+QCFG: "agps/string",(0,1)
+QCFG: "cdmaruim",(0,1)
+QCFG: "cmux/urcport",(0-4)
+QCFG: "ModemRstLevel",(0,1)
+QCFG: "ApRstLevel",(0,1)
+QCFG: "ltectcc/smsstorage"[,(0,1)]
+QCFG: "noauthcheck",(0,1)
+QCFG: "nwscanmodeex",(1-63)
+QCFG: "oostimer",<timer1>,<timer2>,<timer3>
+QCFG: "diversity",(0-1)
+QCFG: "ppp/termframe",(0,1)
+QCFG: "nwoptmz/acq",(0,1),(60-16777200)
+QCFG: "ims",(0-2)
+QCFG: "pcmclk",(0,1)
+QCFG: "tone/incoming",(0,1)
+QCFG: "rssi",(0-20)
+QCFG: "cdmasms/cmtformat"[,(0,1)]
+QCFG: "ltesms/format"[,(0,1)]
+QCFG: "amrcodec",(0-255)
+QCFG: "apready",(0,1),(0,1),(100-3000)
+QCFG: "sleepind/level",(0,1)
+QCFG: "wakeupin/level",(0,1)
+QCFG: "urc/cache",(0,1)
+QCFG: "thermal/modem"[,<level>,<trig>,<clr>]
+QCFG: "thermal/limit_rates"[,<enable>]
+QCFG: "thermal/txpwrlmt"[,<on_off>,<sensor>,<temp_threshold>,<duration>,<trig_cnt>,<crl_cnt>]
+QCFG: "lte/bandprior",(1-43),(1-43),(1-43)
+QCFG: "codec/powsave",(0,1)
+QCFG: "qmisync",(0,1)
+QCFG: "disrplmn",(0,1)
+QCFG: "vts/async",(0,1)
+QCFG: "urc/ri/pin",("uart_ri","uart_dcd")
+QCFG: "iproute_enable",(0,1)
+QCFG: "imsreg/iptype",(0,1)
+QCFG: "stkauto/setupmenutr",(0,1)
+QCFG: "eps/guti_enable",(0,1)
+QCFG: "qcautoconnect",(0,1)
+QCFG: "ftm/mbim",(0,1)
+QCFG: "volte/disable",(0,1)
+QCFG: "roaming/voicecall",(0,1)
+QCFG: "sim/clk_freq",(0,1)
+QCFG: "gpsweek",(0,1)
+QCFG: "multi_ip_package",<enable>,<package_max_len>,<package_max_count_in_queue>,<timeout>
+QCFG: "usage/apmem"
+QCFG: "usage/apfs"
+QCFG: "plmn/autoblock",(0,1),(1-0xFFFFFFFF)
+QCFG: "sim/onchip",(0,1)
+QCFG: "siminvalirecovery",(0,1),(1,60),(1,30)
+QCFG: "sleep/datactrl",(0-7),(50-5000),(0,1)
+QCFG: "sms/omadm",(0,1)
+QCFG: "fast_dormancy",(0,1,2),(1-65535)
+QCFG: "sarcfg",("lte_wcdma","gsm"),max_power,row_grads,column_grads
+QCFG: "hplmn/search_timer",(1-71582)
+QCFG: "efratctl",(0,1)
+QCFG: "w_disable_pin",("airplanecontrol","pa_gpio")
+QCFG: "icf",(0-3),(0-3),(0-3)
+QCFG: "dhcppktfltr",(0,1)
+QCFG: "ntp",(1-10),(5- 60)
+QCFG: "freezeband",(0,1)
+QCFG: "bip/auth",(0-3)
+QCFG: "plmn/addinfbdn",(0,1)
+QCFG: "divctl",("lte","wcdma"),(0-2)
+QCFG: "tcp/windowsize",(0,1),(16-100)
+QCFG: "rrc/control",(0,1),(0-60),(0-60),(0-300),(0,1),(0-60)


What are the return results of the following two commands?


So I was having the same issue. I have been using my x750 for a year now and works like a champ! I have used it with both AT&T and T-Mobile. Recently I just switched back to T Mobile again since they have some really good plans again. However after working for 4 weeks I moved to a new camp ground and got kicked off the tower shortly after arriving. The modem kept saying SIM not registered. No matter what I did it would not work. I had flashed/programmed a new/proper IMEI so the TAC would reflect an actual phone an not a router. In this case I have a free donor phone from AT&T for this. And while the sim would not work in the router it did work just fine in the phone. Well after 4 or 5 days working over T Mobile support, maybe semi social engineering them into doing what I wanted I was satisfied that there was not a new method of identifying unwanted hardware on their network.

So without any real options left I decided to complain about my sim and through the course of a 5th conversation with my T Mobile support agent I learned that sim cards have a shelf life. I guess I new that but had forgotten as I never have one all that long. And in truth I did not this time either, but the one issued to me was an old one, coming up on 3 years. So I had them send me a new one and what do you know popped it in and it worked like day one new. : ) So for me a new sim was all I needed. It is odd how old sims behave… worked on an actual phone just fine but not on the lte router??? Wonder if the charge/voltage applied by the two devices is different and the sim physically wears out over time? The contact points where fine as its was a new to me sim… Anyway thought I would share since this thread popped up on the forum when I searched for SIM card not registered.

1 Like

Old sim may be a problem. On my phone my SIM is sometimes recognized and sometimes not. Maybe just the contact pins are aging.

Contact pins on the device? Maybe… I had reached in and gently bent the arms of the pins back upwards a little so as to apply a little more pressure in case they were loosing contact but it did not help old sim. Also like I said it was a new sim to me, so the contact pads were all like new, almost no ware. But because it was new old stock it must have been getting close to going bad as all I had to do was get a new one and then call to make sure it was from a new batch and after they looked up the sim number and confirmed it was I popped it in and it worked.

I also I took an eraser to the contact pins and to the sim pads just to make sure there was no tarnish or anything.