X750 hard reset of modem

i am very new to this device. Initial impressions are great.

I haven’t found a problem yet, though history with 3gUSB dongle modems tells me that sometimes they need to have their power toggled to reset. In fact my old setup that i am replacing forced me to have an external power reset device to ensure that it came back online while unattended.

On the X750, with the modem module internal, i dont believe usb power toggling works?
Assuming that is the case, does a software reboot of the router power toggle the modem module?

i am really hoping i can get rid of the external power reset when i commission this device at my remote site

thanks in advance

For power cycle of the modem, it is the same as external USB modems. There is a gpio control of the internal modem, you can simply reset it from the UI. The device will power off the modem then power it back.

Hi Alzhao,
firstly thankyou for your great customer support. I can now see why your products get so many positive reviews.

Could i please then confirm, if i soft reboot the router (from within the GUI), that this does also cause a power cycle of the modem? or is it only when the GPIO control is specifically utilised?

thanks in advance


Soft reboot will not cause reset of the modem. Because the modem’s power is not cut.

Hi Alzhao,
could you please advise what GPIO pin is used to power off / on the internal modem on the X750?

Also, could you please point me towards a script that may be appropriate to utilise for this functionality?.. Thanks in advance


I’m also very interested in this, is there a script version or a shell command for this? I’m having no end of trouble with an EP-06 on Verizon (US).

You can control modme power through GPIO0
echo 1 > /sys/class/gpio/gpio0/value means power off
echo 0 > /sys/class/gpio/gpio0/value means power on


This does not seem to be up to date anymore, as gpio0 doesn’t exist anymore.

root@GL-X750:~# ls /sys/class/gpio/
export gpio1 gpio16 gpiochip0 pci_power unexport usb_power

Is there any updated way to reset modem from cli?

I’m not sure if alzhao’s initial response was overlooked or misunderstood or if it just doesn’t solve the problem, but like he said you can reset the modem from the GUI and apparently it should power cycle the modem.

Using pci_power
echo 1 > /sys/class/gpio/pci_power/value
echo 0 > /sys/class/gpio/pci_power/value

This solves the problem, just turn it arount (echo 0 switches off, echo 1 switches on)

Thanks a lot!

@gladly : Webinterface is not an option. We are using the router as emergency acess for pfSense-Router. So in case of emergeny, there is no way to access webinterface if wwan isn’t working. So we have to write a watchdog.

When I use these commands to reset the modem, I get a strange change in the device location when it reboots. Goes from /dev/ttyUSB3, to /dev/ttyUSB4 with an accompanying message of “SIM not registered.” This causes issues with other cli commands (gl_modem AT ATxxxx) no longer working - even though the internet still works.

Using the GUI “Modem Reset,” the modem stays on ttyUSB3 and maintains working cli commands.

Do you know why the device address seems to change when power cycling the gpio? Same thing happens when using gl_modem AT AT+CFUN=1,1.

Do you have other usb devices connected on X750?

When you reboot, does the ttyUSB revert to correct numbers?

I do have another usb device connected. I was just using the USB port to power an espcam. If this is the cause, I can probably find an alternate solution.

Rebooting does cause the ttyUSB to revert to the correct numbers.

I think your espcam created a ttyUSB device which caused the problem.

Power cycle may reset your espcam as well because they are on same USB hub.

I disconnected the espcam and restarted the router and am still having issues where when I restart the modem via the gl_modem AT command, it restarts to ttyUSB4.

Using the GUI “Modem Reset” restarts the modem back to ttyUSB3 like it should.

Strange how the GUI “Modem Reset” works properly every time. What is it doing different than the gl_modem command?

EDIT: Just tried sending the AT command via ‘echo -e “AT+CFUN=1,1” > /dev/ttyUSB2’ and that seemed to work properly. The espcam is still unplugged, but it reset the modem and restarted as the ttyUSB3 as desired.

Can you give me the exact gl_modem AT command you tried which had problems?

gl_modem AT AT+CFUN=1,1

You have found a bug of gl_modem program. The two commands below should have exact the same behavior. It seems that gl_modem locked USB resource so ttyUSB order changed.

Submitted a bug.

echo -e "AT+CFUN=1,1" > /dev/ttyUSB2
gl_modem AT AT+CFUN=1,1

Well, glad it wasn’t something on my end! Thanks for submitting the bug report. Just so you know I’m running firmware 3.201, while 3.212 is available.

I noticed with the echo -e “AT+CFUN=1,1” > /dev/ttyUSB2 command that it doesn’t seem to restart the modem in the same way that the gui “Reset Modem” does. When I use the GUI, the upload and download counters are reset and the modem seems to do a hard reset taking a minute or so to come back and reconnect (hopefully with a fresh connection to the tower). Echo on the other hand seems to reconnect much faster and doesn’t reset the upload/download counters. Now I don’t know if a full reset is better for creating a fresh connection to the tower, but they do seem to behave differently.

What’s the difference? And is there a command that performs the same way as the GUI that I’m unaware of?