X750 modem does not show firmware version

I’ve been without internet for over a week now and I’m desperate. I have a replacement x750 and I’m trying to get it setup. I’ve worked with my internet provider to update the APN to "b2b.static and it is not working. Every time I apply the setting, I wait for a minute and then reboot the router by either unplugging it, waiting 3 minutes and plugging back in or doing a hard reset.

Also another issue I am having is that I’m not finding a firmware version on the modem.

Can anyone please provide some advice?

Thanks

Can you let me know which version you bough? Send screenshot of the above problem.

What is the carrier?

Here is a picture of the firmware that is on the modem and my attempt to do a local upload of the latest firmware. We had this issue with both modems.

Thanks,

Firmware

Here is a snapshot of what I get during the local upgrade of the current firmware

I see. Seems the router cannot connect to the Internet.

I am not sure why local upgrade does not work. Can you refresh the browser and try again?

Pls try this firmware https://dl.gl-inet.com/firmware/snapshots/3.211_beta2/x750/

Hi Alzhao,

I tried the new firmware that you sent and it is working. Thank you so much for your help.

I will continue to work with our provider, No Limit Data, to solve our other issues.

Kelly Maretick

1 Like