Xbox One X refuses to get an IP on 5ghz. Works fine on 2.4ghz. What gives?

Ok so this is a bit weird for me. My Xbox One X can connect to 2.4 ghz just fine. However, it fails to get an IP address from DHCP server on 5 ghz. On the router end, it does get an IP of 192.168.8.125 but for whatever reason, the xbox doesn’t acknowledge it.

Router: Slate (GL-A750S-EXT)

No idea where to proceed from here. I’m happy I can get on 2.4 ghz at least, but I’d prefer to be on 5 ghz just for reliability. (My xbox is near my microwave, which kills the wifi signal)

Could you please try to connect the 5GHz, and look at the log? You can ssh to the router, and execute logread, please show me the result.

I’m going to factory reset. It keeps crashing and rebooting itself when I try to connect any device to it. If the problem is still re-occuring, I will post again. If it fixed it, I’ll close the thread or reply “/closed”. If you don’t hear back from me within 3 days, assumed /closed.

Yup, even after a factory reset and restoring my config manually (yes im aware of backup and restore in luci), it still persists. At the very least, the router is no longer crashing whenever I connect to it. Wonder how to log this btw.

System Log
https://pastebin.com/raw/QhUPih7S

What version of the firmware are you running? 3.022 or the “testing” 3.025?
https://dl.gl-inet.com/firmware/ar750s/testing/

3.025, specifically, this one:

https://dl.gl-inet.com/firmware/ar750s/release/
javascript:getObject(‘firmware/ar750s/release/openwrt-ar750s-3.025.img’)

Tue Jul 16 19:40:06 2019 daemon.info hostapd: wlan0: STA 9c:b6:d0:e1:c7:b9 IEEE 802.11: authenticated
Tue Jul 16 19:40:06 2019 daemon.info hostapd: wlan0: STA 9c:b6:d0:e1:c7:b9 IEEE 802.11: associated (aid 1)
Tue Jul 16 19:40:06 2019 daemon.notice hostapd: wlan0: AP-STA-CONNECTED 9c:b6:d0:e1:c7:b9
Tue Jul 16 19:40:06 2019 daemon.info hostapd: wlan0: STA 9c:b6:d0:e1:c7:b9 RADIUS: starting accounting session C6F2EA33B4A549C5
Tue Jul 16 19:40:06 2019 daemon.info hostapd: wlan0: STA 9c:b6:d0:e1:c7:b9 WPA: pairwise key handshake completed (RSN)
Tue Jul 16 19:41:51 2019 daemon.info hostapd: wlan0: STA 2c:54:91:51:4e:2d IEEE 802.11: authenticated
Tue Jul 16 19:41:51 2019 daemon.info hostapd: wlan0: STA 2c:54:91:51:4e:2d IEEE 802.11: associated (aid 2)
Tue Jul 16 19:41:51 2019 daemon.notice hostapd: wlan0: AP-STA-CONNECTED 2c:54:91:51:4e:2d
Tue Jul 16 19:41:51 2019 daemon.info hostapd: wlan0: STA 2c:54:91:51:4e:2d RADIUS: starting accounting session F4ECFB1E63EC8F72
Tue Jul 16 19:41:51 2019 daemon.info hostapd: wlan0: STA 2c:54:91:51:4e:2d WPA: pairwise key handshake completed (RSN)
Tue Jul 16 19:41:51 2019 daemon.info dnsmasq-dhcp[3562]: DHCPREQUEST(br-lan) 192.168.8.125 2c:54:91:51:4e:2d
Tue Jul 16 19:41:51 2019 daemon.info dnsmasq-dhcp[3562]: DHCPACK(br-lan) 192.168.8.125 2c:54:91:51:4e:2d XBOXONEX

It seems the station *c7:b9 had connected to 5GHz AP, but cannot get IP address, while station *4e:2d had got an IP address.

Ok so how do I fix this?

Is one phone can connect to it, but another one cannot? Am I right?

If so, I am not sure why, maybe you can try to use static proto on your phone instead.

A) It is not a phone, it is an Xbox One X.
B) It can connect on 2.4 ghz, but not 5 ghz.
C) I’ve tried assigning a static IP address, on both the router end and the device end.
D) I’ve tried a factory reset.

Tue Jul 16 19:40:06 2019 daemon.info hostapd: wlan0: STA 9c:b6:d0:e1:c7:b9 IEEE 802.11: authenticated

Tue Jul 16 19:41:51 2019 daemon.info hostapd: wlan0: STA 2c:54:91:51:4e:2d IEEE 802.11: authenticated

There are two stations try to connect to 5GHz AP.

One is the main network, the other is guest. Both 5 ghz fails to connect.

Try setting option wmm ‘0’ under the wireless config for your 5GHz interface. Can be done in Luci under Network > Wireless > radio0 > Interface Configuration > General Setup > uncheck WMM Mode.

That fixed it. Thanks. Any idea why having WMM Mode enabled causes this problem?

I’m not sure why it causes issues for some devices. It seems to be prevalent with iOS devices primarily, but I have also seen it with others to a lesser extent. Often it will produce an “incorrect password” error before actually prompting for password entry.

1 Like

Ok can we get wmm working for the xbox? Having it disabled kills my internet speed on 5g, but having it enabled prevents the xbox one from connecting properly. So annoying…