XE300 EP06-A error forwarding SMS

On receiving an SMS on the assigned number for the SIM, this is what I get forwarded to my phone:


I’m running 3.203-0701. Previously, with an earlier version of the firmware this did work, as I can still see the texts on my phone.


Also, on the Internet page, the envelope for SMS messages has the red number, showing that there are messages. Clicking that takes me to the messages page, but all I get there is the spinning circle forever.

Tried a modem reset, but still no change.


To forward message, email is much better than sms. Sending sms via the modem could be tricky. I never get it working with my carrier.

Also it seems your sms function is having an error. Is it possible to do a firmware reset?

Are you suggesting just a “revert firmware” back to factory settings. Or reload the firmware via uboot.

Also, if the messages page will show the received SMS, then I don’t really need to forward with either SMS or e-mail, but that doesn’t appear to be working despite being the simplest solution.


Revert back to factory settings are OK.

OK, did the following:

  • Revert firmware
  • Wait for re-boot
  • Went through first time sign-on, setting language and password
  • On Internet panel verified I was connected to correct cell network
  • On 2 different devices sent SMS to XE300 phone number
  • Waited for “envelope” to show received texts
  • Hit envelope to go to Message screen

All I get at this point, is the spinning circle and the texts don’t show. I didn’t change any other settings at all.


1 Like

So I tried your other suggestion of using e-mail to forward the texts. This is what I got:

First tried with PDU mode new (with CSA): PDU ERROR: Position 43,6: Invalid character(s) in date of Service Centre Time Stamp: “1B-10-19” Next tried with PDU mode old (without CSA): The PDU data (09) says that this is a sent message. Can only decode received messages. No success. This PDU cannot be decoded. There is something wrong.

Based on the this and the fact that I cannot open the “Message” page leads me to believe the error is in the reception of the SMS, not any attempt to forward it.


Seems it is decode problems. Only send English text.

That’s all I am sending.

I also loaded Minicom to try and see what I could gather by issuing the AT commands interactively, but that doesn’t really work, as the AT commands being issued on a regular basis by the firmware break what I’m typing in. There’s not enough time between each of the firmware commands to type any meaningful AT command.


I don’t think the firmware is using too any AT commands.

In Minicom I see a response and “OK” every 5 or 6 seconds: CREG: 0,5, CSQ: 12,99 and (less frequently) QENG.

Which doesn’t leave enough time to type in any command.


Is there any way to stop the firmware “chatter”, so I have time to type in commands to determine if my issues are in the EP06 firmware of the GL firmware.


The EP06 does not support GMS, so in many cases, you cannot receive and send SMS messages. You can ask your carrier whether SMS messages support LTE channel.

What is GMS:

  • Google Mobile Services - Probably not
  • Geographic Messaging Service - Don’t know of anyone using that yet
  • GMS - They appear to be a service provider

So, nothing that I can find that relates to a messaging standard.

So why does the Quectel EP06 AT Commands Manual have a complete section on Short Message Service Commands. That kinda suggests they do support it.

Sending an SMS from the XE300 works fine, as I receive that on my phone, which proves they DO support SMS. (Albeit I get the message twice, but hey, it still works). Responding to the message shows as a message received, so something understands the reception, but trying to read it gives all the issues documented above.


Sorry, I wrote it wrong, it’s GSM, it’s a second generation of mobile communication, text messages are usually transmitted on this channel

The EP06 supports SMS, but requires LTE channels to support SMS, depending on your carrier’s support.